Keyboard language resets @ reboot 13.2

Hello, I found a previous post on older release with similar issue bot no solution.

I sat keyboard and language to Norwegian at install, but i have for long time now had to go into YAST and set me keyboard to Norwegian at each time i have had a reboot.
there is no visible change in layout in YAST, but choosing norwegian and apply settings fix this.

It resets to default english layout.

Any idea on how to make it always boot with Norwegian layout as default, or as tho why this migth happen?

On 2015-01-19 21:46, skjeggape wrote:

> It resets to default english layout.

How about the keyboard in text mode?
ctrl-alt-f1, log in, and try.
(ctrl-alt-f7 to return to graphics mode)


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

What’s set in /etc/X11/xorg.conf.d/00-keyboard.conf?
And what’s in /etc/vconsole.conf?

Try to set the layout yourself in /etc/X11/xorg.conf.d/00-keyboard.conf, this should work for the X session.
For the text console you have to edit /etc/vconsole.conf and run “sudo mkinitrd”.

Normally you should not have to do that though. It should just work when you set it in YaST (it does here), but there are problems with certain keymaps apparently.
An update is already running:
https://bugzilla.opensuse.org/show_bug.cgi?id=897803

System starts with English layout also in CLI not just in X.

You can say im glad i don’t have any of the Norwegian extra 3 letters of the alphabet after Z in my password, now they represent ; ’ :slight_smile:

It seems as that bug is what also affects me, I will add myself to that bug report, thanks for pointing out :slight_smile:

00-keyboard.conf

Read and parsed by systemd-localed. It’s probably wise not to edit this file

manually too freely.

Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “no”
Option “XkbModel” “microsoftpro”
Option “XkbVariant” “basic”
EndSection

vconsole.conf

KEYMAP=no-latin1

but for some reason it still default to english layout. As in the bug report Nowegian is preselected, but i have to apply it there for it to work, so it seems as these two files are overridden somewhere.