Keyboard Keys swapped


I have been a SuSe user for over 4 years now and recently upgraded to SuSe 12 from 10.3. All installations are MidSum checked.

I have always had a problem with the " key typing th @ key instead (Only since SuSe 10.3 - not in previous Fedora distros - sorry “flavours”).

I think there’s a few other non-letter keys too but I use them rarely. I have tried 3 types of keyboard - all different brands all with the same problem.

Currently I am using a genuine Microsoft Digital Media Keyboard -3000-v1.0. I have Num Lock on, Fkeys are working. I have tried USB and PS2 connections but they are all the same.

The SuSe installations is set on English US and no other languages are used on this computer.

(I also have a second problem with a printer but I’ll list that separately - I don’t think it’s related to this).

Ok I see a few readers.

Is it happening only to me?

If you have this problem too, in SuSe 10.x 0r 11, can you post here so we can get some idea if this is a common fault? :frowning:

There is nothing more frustrating than a keyboard that has a few transposed keys but it is fixed! :open_mouth:

Speechmarks are of paticular concern. When the keyboard was set onto “English UK” the speechmarks key becomes the @ key and vice versa. The brackets and a few other less frequently used keys are also effected.

The simple solution was to enter Yast and reset the keyboard as “English US”

I woke up to this when I saved some spreadsheet work. When I rebooted, some accounting data I computed from another cell on the spreadsheet was in pounds symbols rather than Dollars. :slight_smile: