Keyboard issues for KDE3 based applications

Possibly due to the latest update of packages, I have a problem with the keyboard and accented Greek characters to all KDE 3 bases applications.
My setup is:

  • openSUSE 13.1
  • KDE 4.12.2
  • KDE 3.5.10

The problem is that at KDE 3 applications, the keyboard seems to ignore the dead key. In order to add an accent to a letter, I need to press “;” and then the letter. So, “;” and α will produce: ά.
However, at KDE 3 based applications, instead of “ά”, it’s written as “´α”!

So, what I do understand, is that KDE3 based applications do not recognize the “dead key”. I don’t know if I can open a bug for that, but I need an solution (for sure).

So it does work as expected in non-KDE3 applications, only KDE3 applications are affected, right?

It works fine here with a german keyboard layout, and with the greek layout as well…

How did you actually configure the keyboard layout? Did you do that in YaST->Hardware->System Keyboard?
Then it should apply to all applications.

Please check the “Regional and Accessibility”->“Keyboard layout” settings in KDE3’s control center (“kcontrol” in a Konsole).
Is “Enable Keyboard Layouts” activated there? If yes, check that indeed some deadkeys Layout variant is set there, if not the system’s settings should be used as set in YaST.


System keyboard is set to Greek and I have not enabled ANY “Expert setting”.
I have not modified it for ages. It just stopped working (obviously after some updates).

I did, please check the attachments.
Also, I noticed that Alt-Shift doesn’t change the keyboard and I was forced to use the flag in order to do so.

Sorry, I can’t reproduce that here. Greek deadkeys work fine here (AFAICT) even with the same settings as you.

Does it work in YaST’s test field?

Does it work if you disable “Enable Keyboard Layouts” in kcontrol?

Does it work if you run “setxkbmap gr” in Konsole? This should change the keyboard layout for the whole current X session.

Regarding Alt+Shift, AFAICS this can be configured on the third tab “Xkb Options”.

And where did you install KDE3 from? I’m using the one from the standard openSUSE repo, not KDE:KDE3. Not sure if that could make a difference though.

OF course, it’s QT4 based, remember?

No change.

And it is. But, I don’t care too much about it.

KDE 3 was never un-installed. :slight_smile: The repository I use is:

I will revert back to OSS packages and see from there. Although, I do not believe that those packages are the problem.

I solved it with the following actions:

  • Removed all IBus packages
  • Downgraded all
    KDE packages to OSS provided ones.

@Admins: Please change the title to “SOLVED”.

Not necessarily.
The version included in openSUSE 13.1 is Qt4 based, yes.
The version in Factory (which will become 13.2) is Qt5 based already, and there’s a Qt3 based version in KDE:KDE3.

And then there’s the Gtk and ncurses versions of course.

KDE 3 was never un-installed. :slight_smile:

But it has been installed from somewhere at one point in time, when you upgraded f.e. :wink:

Anyway, glad to hear it works again now! :slight_smile: