keyboard: German layout

Hello people,

I have a Lenovo ideapad s205 and I bought it in Germany so it has a German layout keyboard.

In the system settings in Gnome, I found this

keyboard picture

but the phisical keyboard on the machine has a different layout, so I can’t type all the symbols. For example I can’t type the tilde ( ~ )

When the machine booots up I press f4 and choose the German keyboard layout and the Italian as a default language.
How do I instruct my enviroinment so that the right layout is used ?

Thanks

In principle you tell YaST that you have a German keyboard; you should then not need to do anything on boot up.

You then need to find the software that will give you a soft Italian keyboard and set it to Italian; you should then not have to do anything when you load Gnome. As I am a KDE user, I do not know what the relevant software is in Gnome.

Telling YaSt the kardware configuration enables the software to map the soft keyboard to the actual keys you have.

My suspect is that the setting xkbmodel = pc104 has something to do with this.

How could I test different settings for that key (xkbmodel) ?

Thanks