Keyboard connected but can't type

Hello all:

This is a new one, for me anyway.

I have an older e-machine running 11.1 and out of the blue, I can no longer type into any app.

Naturally, thinking it was a defective keyboard I swapped it out, no luck. Thinking it might be the plug on the motherboard, I use a USB keyboard, still no luck.

I restarted the machine each time. Then the light bulb went off, when I restart the computer I have to type in my password. Restarting again, sure enough, I can type in my password but once in I can’t type in any app., Thunderbird, Firefox, Kwrite, OOword, …

How is this possible - and more importantly, how do I fix it?


Boot to runlevel 3
You do that from the boot menu, clear boot arguments and just type: 3
login as user at the CLI
then go su

start yast with: yast

It’s keyboard navigated so hope it works. Go to hardware and try and configure the keyboard.
When done:

Well that worked - mostly, thanks.

I’ve never had a reason to reconfig a keyboard. While usable now, you have to press and hold the key (for about a .5 - 1 sec.) before it registers.

I see a way to change the repeat rate and delay but not a way to change the initial the rate. I’ll play with that but if you have a suggestion,…

Thanks again,

It might be more related to running processes hogging things.
Disable beagle if you have it and either stop it from starting at boot or remove it completely.
What spec have you. RAM?

Are you running KDE 4.2.4? I and some other people on the Net have found that ‘slow keys’ can randomly get enabled in 4.2.4. It’s under Configure Desktop, Accessibility.

Please check this as well:
The keyboard configured in Yast should be the same as the one configured in KDE !!. I changed to one of these Apple keyboards and had this problem yesterday. After setting it in Yast it did not work as it should (very slow response, up to 15 minutes before character appeared, so looked dead). By mouse I changed the keyboard in the systemsettings as well, logged out and in, problem gone.