Keyboard configuration rejected

After installing the proprietary ATI graphics driver, SAX2 does not detect my display anymore. But that isn’t the problem- the problem is when I try to change the keyboard “type” using SAX2 and test it, the test displays an error ( attached ). Any help would be appreciated.


Did you try to read the log file as suggested in the error message?

It seems to me that your problem is not the keyboard, but the video configuration. Sax deals with video/keyboard/mouse as one “set”, so to speak. When you start it, even if trough the mouse settings modules, it will check/report on the whole “set”.

Also do read the installation instructions for the ATI binary drivers. You don’t use sax, but a line command like ./ati-settings --initial, or something like that, and restart X. In my experience with an onboard ATI graphics and OS 11.0/KDE3 that’s the way it worked. Not sure about 11.1.

Late thanks to brunomcl above, but the problem is not yet solved.
Any further help from anyone would be appreciated.

Here’s the story-
I have the latest ATI driver downloaded from the OpenSUSE 11.1 repository. Thereupon (am I antique?), I ran
aticonfig --initial -f
Ok, everything is quite alright upon logon, and I can run glxgears and can enable kwin compositing without problems.
Here’s the output of fglrxinfo-
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X300
OpenGL version string: 2.1.8395 Release

Now, the questions-

  1. how do I check which version of ATI driver I’m running, and also which version of Xorg I have. Struggling to find the versioning information on these two on command line.

  2. The keyboard type selected in SAX2 is ‘Microsoft Natural keyboard’ whereas I’m running an IBM Thinkpad T43. When I try to change this in SAX, it does not allow me to. Starting sax2, I get this warning-
    When I choose a different keyboard now, and try to test the configuration, I get the error-
    In the end, I’m unable to save with the changed keyboard.

  3. Jumping the gun, Sax2 does not list my keyboard type. How do I determine which keyboard would be the closest match? Mainly, I’m interested in setting the ‘Fn’ button on my keyboard as the meta key. As previously said, this is an IBM Thinkpad T43.

To summarize, the ATI driver is working fine, but I think SAX2 does not seem to be taking too well to the change in display driver and is not allowing me further configuration change.

thanking in advance,

On the info about installing the ATI driver there’s a suggestion posted how to start YaST, in a way that starts a particular module or prevented reading the xorg.conf file.

I’m wondering if you were able to select the keyboard initially when using the Vesa or Radeon (HD?) driver.

Are you running SaX2 from text mode, by putting system into run level 3 (at # prompt type “init 3” or add 3 to boot line). It’s complaining about entry for screen being invalid, so I guess it doesn’t want to update the file, to avoid breaking graphical mode of the system.

Hey Rob, thanks that fixed the problem.
As you reminded, in the SUSE instructions page for ATI driver, there’s a suggestion for the command-
SaX2 -r -m 0=fglrx
When I ran that earlier on the normal init level (5?) sax hanged, but after init3, sax2 correctly configured the display & driver, and now allows me to change the keyboard.

Any pointers on how to choose the best keyboard for a Thinkpad T43 (unlisted in sax).

thanks a bunch, repped.