Keyboard bug after using zypper update/patch OpenSuse12.3

I have downloaded OpenSuse 12.3 from software.opensuse.org: Download openSUSE 12.3 .
Checked MD5 and Media verification and both passed. Installed it on my laptop:
NP-R510 - OVERVIEW | SUPPORT | SAMSUNG UK.
Exact model is NP-R510H

cat /etc/SuSE-release
openSUSE 12.3 (i586)
VERSION = 12.3
CODENAME = Dartmouth

Everything seems to be working fine untill i decide to use konsole to update my
os - using commands such as :
zypper patch or zypper update I did manage to get all updates as advised and so
I thought that I’ll be able to use OpenSuse soon.
However after reboot my English (uk) layout seemed to be broken typing half of
letter characters resulted in number characters being written. I used Xev to
verify if characters i type are correct characters and so it showed that
characters like i on keyboard displayed as if i pressed 5… there were many
more and I had multiple duplicates for numbers and some other characters when at
the same time many letters were missing.

I managed to “fix” the problem once after changing keyboard layout to US and back to UK, however it broken again after restart. Then I was unable to repeat the fix.
Restarted several times and I managed to get keyboard working again after switching to Polish layout and back to UK at which point I was not able to repeat it again.

This issue affacts laptop’s keyboard only and does not affect at all usb attached keyboard which I am using atm to describe the problem. Since I discovered the problem first I reinstalled OpenSuse 3 times:
First Install - using zypper patch command caused the keyboard to fail (fails every time after restart if it somehow manages to get right again)
Second Install - using zypper update command caused the keyboard to fail again (fails every time after restart if it somehow manages to get right again)
Third Install - no updates and keyboard works flawlessly on specified settings.

Additionally this problem seems to be affecting only gui part of the OS as when I used konsole from ctrl+alt+f2 all keys did give correct output.

I am not sure what else I can provide but here is a result of sudo zypper list-updates > updates.txt

zypper updates - keyboard failure - Pastebin.com

Summary:
Changing keyboard layout seemed to have an immediate effect two out of about 7-10 tries to change keyboard layout, untill i rebooted and it was broken again.
ctrl+alt+f2 mode works ok with the keyboard, however upon exit using ctrl+alt+f7 in gui it does not work at all.
external usb keyboard works fine and problem seems to be affacting only keyboard on laptop
Problem occurs only after zypper update/patch and always comes back upon reboot.

OpenSuse keyboard bug - Pastebin.com - Whole description in pastebin just in case.

So what hardware. I don’t think I have seen this problem reported before so it may well be hardware related.

I am sorry if that is too much info - used YaST2 to get hardware specs and If that too much to look for anything specific please supply me with a way of providing more useful info.

YaST2-hardware-information - Pastebin.com

Was thinking more like make and model LOL

Also might be interesting on what video hardware and driver. If X is what interprets keys in a GUI so it may be a video driver or configuration problem

On 2013-10-24 18:16, gogalthorp wrote:
>
> Was thinking more like make and model LOL

It is on the first post, first paragraph.

> Also might be interesting on what video hardware and driver. If X is
> what interprets keys in a GUI so it may be a video driver or
> configuration problem

iluzek, find out how is the keyboard in text mode (ctrl-alt-f1, login,
test - you can use ‘joe’ editor.

Some laptops can emulate a numerical keypad in the middle of the
keyboard, substituting letters with numbers. Usually a special function
key does the switch. It looks to me as if your keyboard is switched to
this mode, maybe erroneously as no keyswitch was requested.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

>iluzek, find out how is the keyboard in text mode (ctrl-alt-f1, login,
>test - you can use ‘joe’ editor.
This did not work and as I checked ctrl-alt-f2 again it didn’t either this time.

>Some laptops can emulate a numerical keypad in the middle of the
>keyboard, substituting letters with numbers. Usually a special function
>key does the switch. It looks to me as if your keyboard is switched to
>this mode, maybe erroneously as no keyswitch was requested.
This was the helpful part…I tested all keys and fn key and f11 seemed to do the trick. Settings did not persist thru restart but me and my friend figured out that it’s a numlock setting somewhere. Tried Keyboard Settings > Numlock on (Turn off) this worked… but again did not persist thru restart.

My friend remembered that he has seen numlock option somewhere in regards to bios so I changed settings in location:
System Keyboard layout > Expert Settings…> Start-Up States > Num lock On - was YES switched to NO and problem is solved now.

Thank you very much for hinting about that key that as it turned out was num lock setting.

However this does not exactly explain why nobody else seemed to have that problem before and what caused settings to change. Insight for developers might be useful if someone has a clue.

Cheers
Iluzek

Might consider Solved/Closed

On 2013-10-24 23:36, iluzek wrote:

> On - was YES switched to NO and problem is solved now.

Good :slight_smile:

> Thank you very much Saludos for hinting about that key that as it turned
> out was num lock setting.

He, “Saludos” is Spanish for greetings or cheers or equivalent. My name
is Carlos. :slight_smile:

> However this does not exactly explain why nobody else seemed to have
> that problem before and what caused settings to change. Insight for
> developers might be useful if someone has a clue.

Maybe it only happens with certain hardware.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

> He, “Saludos” is Spanish for greetings or cheers or equivalent. My name
is Carlos. :slight_smile:

Hehe, kinda figured that and amended 3 minutes later but apparently it didn’t update changes =(. Thank you again :stuck_out_tongue:

On 2013-10-25 02:36, iluzek wrote:
>
>> He, “Saludos” is Spanish for greetings or cheers or equivalent. My
> name
> is Carlos. :slight_smile:
>
> Hehe, kinda figured that and amended 3 minutes later but apparently it
> didn’t update changes =(. Thank you again :stuck_out_tongue:

Welcome. :slight_smile:

No, often when people edit their posts those of us using nntp to access
the forums only see the first version of the post.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))