keyboard backlight on samsung notebook 9 (NP900X3L)

I’m unable to turn off the keyboard backlight on my samsung notebook 9 (NP900X3L) with Leap 42.1 and Plasma 5. The backlight turns on immediately after the power button is pressed and stays on until the computer is completely off. I don’t care about being able to adjust it, I just want it off. I haven’t been able to find anything in the user interface that refers to the keyboard backlight.

I’m able to adjust the display brightness and control the volume using the fn + F(x) hotkeys.

When I boot into windows 7, the keyboard backlight stays on until the samsung ‘easy settings’ utility starts, at which point I can turn it on and off and control the brightness. There doesn’t appear to be any way to adjust backlight in the BIOS.

Here’s some info on my setup:
Samsung Notebook 9 (NP900X3L)
Leap 42.1 and Plasma 5 dual boot with Windows 7
I had to upgrade the kernel to 4.7 because I was having compatibility issues with the skylake cpu.

Any help would be much appreciated.


Hi, I never had a Samsung with keyboard backlight but on another notebook adding "acpi_osi= " (including the trailing blank) to the boot command line enabled the relevant Fn keys.
You find the boot command line by pressing “E” (for Edit) at the GRUB boot menu and looking for the line beginning with “linuxefi”, then press F10 to boot.
If that works, you can make it permanent with Yast2 Bootloader, “Kernel Parameters” tab, adding to “Optional Kernel Command Line Parameters”.

Okay, I’ve tried adding that to the boot command line and I’m still not able to change the keyboard backlight. Additionally, the display brightness hotkeys, while still bringing up the onscreen brightness display, no longer actually adjust the brightness.

Also, I’ve just noticed that the keyboard brightness seems to be changing (with and without the command line option) based on ambient light.

I found something else on an ubuntu forum:

A slightly safer way, which requires a reboot to work, is to set the keyboard backlight level in the UEFI variables.

 On my system:
 # cd /sys/firmware/efi/efivars
# ls *KeyboardBacklight*
# xxd -p SecKeyboardBacklightLevel-2f440835-38c4-44b6-b7e4-4f321c8b4189
# echo 0700000005 | xxd -p -r > SecKeyboardBacklightLevel-2f440835-38c4-44b6-b7e4-4f321c8b4189
# reboot

You can change that last byte from 00 through 06 or so. Don't change  the first or other bytes. At some stage during the next boot, it will be  read into the KBLL value mentioned above.

The corresponding file in this directory on my computer is ‘KBDBacklitLvl-5af56f53-985c-47d5-920c-f1c531d06852’. The output of

xxd -p KBDBacklitLvl-5af56f53-985c-47d5-920c-f1c531d06852

is 0700000003. Since I’m trying to turn off the backlight, I want this set to 0700000000. When I run (as root)

echo 0700000000 | xxd -p -r > KBDBacklitLvl-5af56f53-985c-47d5-920c-f1c531d06852

I get

bash: KBDBacklitLvl-5af56f53-985c-47d5-920c-f1c531d06852: Permission denied

Does anyone know why I get ‘permission denied’ while running this command as root?

I finally got this to work. Just in case anyone has this problem in the future, the problem was that the file had the ‘immutable’ attribute. I removed it, ran the code above, rebooted, and now the keyboard backlight stays off.

Good find, thanks for sharing!

Dude! Thank you! I worked on this for an hour before finding your post…

I’m in the opposite position: want to enable the light, but so far no dice (but thanks for your post! Got me to the next step in the process)