keyboard backlight Asus G73SW

Hi,

Just dual-booted a brand new G73SW-X2, running Windows 7 / OpenSUSE 11.4 x86_64. Most features ran out of the box with only a small glitch with the video driver. Solved after installing the latest driver from the opensuse website.

The problem here is the keyboard backlight and keyboard volume keys, which don’t work. The best I found after googling was something for Ubuntu on a desktop keyboard using “xset led 3” where 3 corresponded to the particular led to be turned on. It didn’t work on 11.4.

Does anyone know how to do this?

Z.

Is your keyboard backlight supposed to come on when you type? Or do you have a dedicated button to turn it on/off?

As for you volume keys, are they FN+X or are they dedicated buttons? You will probably need to listen to the keyevents firing when you touch them and then create an ACPI scrip to handle the fires.

Good luck.

Hi,

The keyboard back lights can be turned up/down with FN+F3/F4.

There are many other features associated with FN+F# and none of them work (sleep, wifi, screen brightness, mouse pad on/off, volume up/down/mute, etc.). In fact, I can’t even adjust screen brightness from the battery power management module.

As you can tell, I am very new to this. Can you point me to a good reference or HOW-TO for listening to key events and writing ACPI scripts?

Thanks,
Z.

Hi!
I have the same problem (G73SW opensuse 11.4) and no backligth keyboard.
did you find something to fix this ?

thanks a lot.

I found a thread on the ubuntu forums with instructions how to do it for ubuntu 11.04. You basically have to apply the asus-wmi patch and possibly the asus-nb-wmi patch. Haven’t had time to try it yet.

[ubuntu] Asus G73 Backlit keyboard issue [Archive] - Ubuntu Forums](http://ubuntuforums.org/archive/index.php/t-1752900.htm)

If you still have windows you can log into it and activate the keyboard lights. They will turn on when you reboot linux but you can’t modulate them. Right now none of the FN-* functions work.

Z.

I have sound and screen brightness buttons working after choosing “Asus notebook” somewhere in the keyboard settings. But touchpad and the keyboard backlight buttons still don’t work. Suspend also doesn’t work - I have to reboot the notebook. OpenSUSE Thumbleweed.

I got sleep and hibernate working by doing this. But the backlight still doesn’t work.

Thanks for the tips Tyakos. Right now I am facing a bigger problem. An update through PackageKit broke wifi altogether. Have you had a chance to look at asus-nb-wmi? It should have all the fixes.

Here you go: http://ubuntuone.com/p/14VF/.
Hope it helps.

Thanks, but the archive is empty… unless I missed something.

Are you using 11.3 or 11.4? Where are these keyboard settings? I can’t find anything under Configure Desktop and System Keyboard Layout.

Configure Desktop - something like input devices settings.
This may help: http://ubuntuone.com/p/14Yj/

I’ll try to make a custom kernel with a patch today before 10 pm GMT. I’ll give you an rpm if you like.

Hi. I need help. What happens on Asus g73s(w) if you:

echo 0x00050021 > /sys/kernel/debug/asus-nb-wmi/dev_id

echo 0x82 > /sys/kernel/debug/asus-nb-wmi/ctrl_param

cat /sys/kernel/debug/asus-nb-wmi/devs

.

Does the backlight turn on?

I have built a patched kernel.
WARNING Use it at your own risk!

WARNINGThis package installs a new kernel.
WARNINGYou working kernel will NOT be deleted
Run

rpm -ivh [the rpm]

You will need to boot with this kernel.
First create an initrd file by doing

mkinitrd

Then you will have to edit GRUB’s menu.lst
You can do it either from YAST or yourself.
To do it youself just
1)open /boot/grub/menu.lst
DON’T MAKE ANY CHANGES TO YOUR WORKING KERNEL LINES IN menu.lst
If you do not understand what you are doing backup menu.lst first
2)copy your working kernel’s lines
3)paste them in the end of the file and
a)change* title Desktop – openSUSE 11.4 - 2.6.39.2-36*(or whatever) to* custom kernel*(or whatever)
4)change * /boot/vmlinuz-[your kernel version] * to vmlinuz-2.6.39.3g73-patched and do the same with initrd lines

Save.
Reboot.

Choose your created boot option.
If you are using Nvidia drivers X server might not start.
To test you backlight do

echo 0x00050021 > /sys/kernel/debug/asus-nb-wmi/dev_id

echo 0x82 > /sys/kernel/debug/asus-nb-wmi/ctrl_param

cat /sys/kernel/debug/asus-nb-wmi/devs

The backlight should turn on.

If you are happy - install Nvidia drivers: SDB:NVIDIA the hard way - openSUSE

If not - boot from your old kernel and delete mine using YAST and restore your menu.lst from backup.

The buttons still don’t work for me but you can change backlight brightness by changing 0x82 to
0x80(off)
0x81(low)
0x83(high)
in the

echo 0x00050021 > /sys/kernel/debug/asus-nb-wmi/dev_id

echo 0x82 > /sys/kernel/debug/asus-nb-wmi/ctrl_param

cat /sys/kernel/debug/asus-nb-wmi/devs

Here is the rpm: http://ubuntuone.com/p/14pr/

You can always try to compile the kernel yourself.
**The patch is **

Thanks to lwarranty from http://www.scottsautorepair.net/microsoft.sucks/G73SW.keyboard.lights.html (here)

You can download kernel source for the Nvidia drivers from The Linux Kernel Archives and unpack it to /usr/src. And change the source linux link.
Otherwise I’ll post the src.rpm tomorrow. Sorry about that.

If you want to install your NVIDIA drivers use this kernel source. Unpack it to /usr/src/ and create a link “linux” for the unpacked folder in /usr/src/

http://ubuntuone.com/p/14xe/

From NVIDIA-Linux-x86_64-275.19.run:


--kernel-source-path=KERNEL-SOURCE-PATH"
    The directory containing the kernel source files that"
    should be used when compiling the NVIDIA kernel module. "
    When not specified, the installer will use"
    '/lib/modules/\`uname -r\`/build', if that directory exists. "
    Otherwise, it will use '/usr/src/linux'."

This is it. Write me if you used these instructions please.