Kernel5.2 and Nvidia Driver dont work

By now the Kernel 5.2 has arrived for quite a while, until the new update of today 5.2.5 the drivers downloaded from Nvidia’s function worked, now they fail and there is no way to install them, the Repository no longer works from a long time

What version of the run file? I have 430.40 working here fine with the 5.2.5 kernel…

 inxi -GxxSz
System:    Host: grover Kernel: 5.2.5-1-default x86_64 bits: 64 compiler: gcc v: 9.1.1 Desktop: Gnome 3.32.2 wm: gnome-shell 
           dm: GDM Distro: openSUSE Tumbleweed 20190805 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0152 
           Device-2: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nvidia v: 430.40 bus ID: 01:00.0 chip ID: 10de:128b 
           Device-3: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: vfio-pci v: 0.2 bus ID: 02:00.0 chip ID: 10de:128b 
           Display: x11 server: X.Org 1.20.5 driver: fbdev,modesetting,nvidia,vesa alternate: nouveau,nv 
           compositor: gnome-shell resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Desktop v: 4.2 Mesa 19.1.3 compat-v: 3.0 direct render: Yes 

I have to use the 390.129 that worked until yesterday on kernel5.2.3; today I updated to Kernel5.2.5 and I did the usual procedure from the shell nvidia-installer --uninstall> reboot and reinstall them again

Likely needs patching and creating a custom run file… Check the Nvidia forums for patches, they are pretty good.

Problem solved, in practice at login as usual I used Ctrl + Alt + F2 to enter the shell and compile the Nvidia drivers with the new Kernel, a message would come out telling me that I had to exit the graphical session, but I was out of the session graphic …; it was enough to give init 3 and then start the Nvidia installer and everything went OKlol!

What I do is after installing a new kernel, reboot and press E, add “3” to the end of the linux line and press F10 to boot, then re-install the nvidia driver (use options “-q -s” to skip all the questions), and reboot. Always works like a charm.

Two smal scripts, first to set “init 3” and reboot:


systemctl set-default

Second to install the nvidia-driver after reboot and set to “init 5” and reboot


cd /home/xxxxx/bin/nvidia

#./ -a -q

./ -a -q

#Vboxsetup for the Download from Oracle
#cd /home/xxxxx/bin
systemctl set-default

top is only to see, if purge-kernels.service is working…

Has the Nvidia driver directory been closed or moved?

Was at:

The directory is back up now - as posted in another thread.