Kernel vmlinuz-5.14.21-150400.24.49 dies on boot with i915 video

Thank you for your answer.

Why? What is the problem/difference?

Because he’s pointless on the plate. Why would you want to keep it? Eventually it’s the emergency kernel and won’t boot…

Thanks mrmazda, but i also don’t know what is the use of these default-extra and default-optionnal, as it was automatically put here by opensuse during installation, and i suppose it did for a good reason. Maybe for some so-called trusted computing something hardware i don’t anything about because it’s modern hardware that needs some extra or optionnal drivers. Anyway, if decide to uninstall 49.3, i will do it for all the packages to avoid inconsistencies. (49.3 out !!! as the french say ;o)

I don’t want to keep it, I just want to avoid unnecessary steps where things can go wrong again.
I edited zypp.conf to have multiple kernels available.

multiversion.kernels = latest,latest-1,latest-2,running

At some point, 49.3 will be kicked out automatically, no?
Why should I change anything about it?
Is there a good reason?

My /etc/zypp/zypp.conf ( the default one ) contains only :

multiversion.kernels = latest,latest-1,running

Isn’t it enough ?

IMHO only if a 4th kernel is installed, because with this setting you always have 3 kernels installed.

I prefer to have 3 kernels available. My pleasure … :wink:

Hello i have same problem after today system update.

I set Yast boot config to start with previous kernel, I am asking for information how to get back to the normal configuration with the latest kernel (of course, after the patches are released).

Same issue here on Thinkpad T590 - reverting to kernel 5.14.21-150400.24.46

The patch that provided this kernel has been retracted. So, it’s being taken care of.

Yes! I wouldn’t know why not. No matter, how many kernels you want to keep. You are doing it on (some kind of) purpose. The purpose normally is to be able to fall back on it in case of trouble, isn’t it? And now imagine 49.3 hat not yet been kicked out automatically but happens to be the one you want to rely on because of some (yet unforeseen) trouble in future. Wouldn’t it have been better to be able to fall back to 46…?

1 Like

In yast-software- searched for “kernel” then uninstalled the current version(49). I checked the versions tab and made sure (46) was installed. I’ve been booting from the (46) version. It works fine.

1 Like

I am stuck! I uninstalled the retracted kernel (3) and was automatically given an older one. However, the internet connection Network Manager has stopped working. Shifting to Wicked also does not work!! Without the internet working I cannot do anything to access the repos. I am posting this from Windows 10. I also have Leap 15.3 which is working. I am aware that the info I am providing is sketchy and I will have to add more details. How do I get internet back??

PrakashC

1 Like

Same thing happened to me when I reverted to the older kernel. However, Wicked is working just fine. Network Manager does not work at all. Hoping this will fix itself when the new kernel comes out.

1 Like

i915 is Intel graphics, correct? I guess this explains why my netbook with Intel Core 2 Solo “hung” (rebooted to no graphics) after I did the 15.3 to 15.4 upgrade via changing repositories and zypper dup.

I was, however, able to get to a console with CTRL-ALT-F1. Unfortunately, YaST lost some options, one of them Online Update, so I checked Wi-Fi and it wasn’t working. (My thinking was that no network interfaces meant YaST wouldn’t allow some options.) The netbook has a wired Ethernet port, so I switched to that, which worked, however YaST still lacked Online Update. I used zypper dup again, which finished, however things are broken…

Grub only has two options, instead of the usual four:

Windows Recovery Environment (on /dev/sda1) <— This is normally there.
Start bootloader from a read-only snapshot

The main kernel option and Advance mode are missing.

Start bootloader from a read-only snapshot menu:

openSUSE Leap 15.4 (5.1.4.21-150400.22,2023-03-22T08:27,post,yast repositories)
openSUSE Leap 15.4 (5.1.4.21-150400.22,2023-03-22T08:24,pre,yast repositories)
openSUSE Leap 15.4 (5.1.4.21-150400.22,2023-03-22T08:23,post,yast sw_single)
openSUSE Leap 15.4 (5.1.4.21-150400.22,2023-03-22T08:21,pre,yast sw_single)
openSUSE Leap 15.4 (5.1.4.21-150400.22,2023-03-22T08:21,post,yast sw_single)
openSUSE Leap 15.4 (5.1.4.21-150400.22,2023-03-22T08:18,pre,yast sw_single)

If I boot from the first snapshot, I get to full graphics mode, but since it’s read-only, I can’t update from there. It says there are 265 updates, which is what the last zypper dup I was able to do did.

How do I proceed from here? Is there a way to make a new grub file, to get all the options back? The snapshot shows that I do have a working system now?

Thanks!

1 Like

I just tried to edit to add…

I should have read the help at the top of the first snapshot menu, which says to use “snapper rollback”. I booted to the read-only snapshot and as root, executed the command. I rebooted and the the grub menu had been restored. I’m back up in graphics mode. Now to test and update further…

Assuming you don’t have a firewall blockage, if systemd-network is installed, switch to it using static IP. Enabling it in place of wicked, adding a small config file in /etc/systemd/network, and ensuring a valid /etc/resolv.conf file exists could be all you need. It’s what all my installations use except for one rarely used laptop on which my brother did its only installation.

e.g.

# cat /etc/systemd/network/eth0.network
[Match]
Name=eth0

[Network]
Address=192.168.100.101/24
DNS=192.168.100.100 1.1.1.1 1.0.0.1
Gateway=192.168.100.100
IPv6AcceptRA=no
LinkLocalAddressing=no
systemctl disable wicked.service
systemctl disable wickedd-auto4.service
systemctl disable wickedd-dhcp4.service
systemctl disable wickedd-dhcp6.service
systemctl disable wickedd-nanny.service
systemctl disable wickedd-pppd@.service
systemctl disable wickedd.service
systemctl enable systemd-networkd.service

Make sure the filename root in the network directory matches your NIC’s name, and the IP’s harmonize with your router’s configuration.

1 Like