kernel upgrade issues

I’ve upgraded kernel to on openSUSE 11.1. Before I tried to upgrade to where I encountered the same issue. After reboot it can not find the modules for which puzzled me to no end. Now I have found that the /boot which is on separate partition of ext2 type is not mounted. The mount command does not recognize ext2 and xfs anymore. Clearly the initrd does not have the right modules.

Since this is standard zypper up process I would expect this to work without issues since it has worked until the kernel without issues.

Has something changed with the last 2 kernel versions that requires some extra actions from me and if so what do I have to do.

Maybe the problem starts with the following lines from /var/log/boot.msg

Mounting local file systems…
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
FATAL: Could not load /lib/modules/ No such file or directory
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
modprobe: FATAL: Could not load /lib/modules/ No such file or directory

When I boot this upgraded system it seems that the kernel is still on version according to uname -r

Not sure what has gone wrong here since no obvious errors were reported during the upgrade of the kernel