Kernel update leads to Intel Pro/Wireless 4965 failure

A side effect of a kernel update to 2.6.25.16-0.1-pae is the failutre of my intel Corporation PRO/Wireless 4965 AG connection.

I have tried to resolve this by following clues here, but guess I need help. I have tried compat wireless (compiled and installed compat-wireless-2.6-old. But no joy. Below are a collection of output which should provide some more specifics on the problem.

any help or clues would be very welcome!

----------
# uname -a
Linux linux-nsd1 2.6.25.16-0.1-pae #1 SMP 2008-08-21 00:34:25 +0200 i686 i686 i386 GNU/Linux


# /sbin/lspci -nn
14:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection [8086:4229] (rev 61)
-------

extract from
# dmesg | less

iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.23ks
iwl4965: Copyright(c) 2003-2007 Intel Corporation
iwl4965: Detected Intel Wireless WiFi Link 4965AGN
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) -> IRQ 21
PCI: Setting latency timer of device 0000:00:1b.0 to 64
iwl4965: Tunable channels: 13 802.11bg, 19 802.11a channels
phy0: Selected rate control algorithm 'iwl-4965-rs'
ACPI: PCI interrupt for device 0000:14:00.0 disabled


--------------------
 # /usr/sbin/iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

----------------
# /usr/sbin/iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down


----------


# lsmod |grep iwl
iwl4965               129248  0
iwl3945               106332  0
mac80211              190616  15 b43legacy,b43,ath5k,rt2x00usb,rt2x00pci,rt2x00lib,iwl4965,iwl3945,rtl8187,rtl8180,zd1211rw,adm8211,p54usb,p54pci,p54common
firmware_class         25984  14 b43legacy,b43,rt2x00lib,iwl4965,iwl3945,zd1211rw,p54usb,p54pci,usb8xxx,libertas_cs,ipw2200,ipw2100,microcode,pcmcia
-------------
# hwinfo --wlan
05: PCI 1400.0: 0282 WLAN controller
  [Created at pci.310]
  UDI: /org/freedesktop/Hal/devices/pci_8086_4229
  Unique ID: y9sn.AI5DsHTk+F7
  Parent ID: Z7uZ.2DtjpW0qNEE
  SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:14:00.0
  SysFS BusID: 0000:14:00.0
  Hardware Class: network
  Model: "Intel PRO/Wireless 4965 AG or AGN Network Connection"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x4229 "PRO/Wireless 4965 AG or AGN Network Connection"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x1101
  Revision: 0x61
  Driver: "iwl4965"
  Driver Modules: "iwl4965"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xfe300000-0xfe301fff (rw,non-prefetchable)
  IRQ: 19 (no events)
  HW Address: 00:1d:e0:bf:b9:1b
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v00008086d00004229sv00008086sd00001101bc02sc80i00"
  Driver Info #0:
    Driver Status: iwl4965 is active
    Driver Activation Cmd: "modprobe iwl4965"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #16 (PCI bridge)


I have the same problem since I updated to 2.6.26… if I do not start linux with the wireless button on. Unless it still works great. I even now have the led on.

Please help.

shouldn’t happen really. try uninstallling the drivers in yast and then reinstall them again, then check the module name in network device settings…you may find it is still the old driver. you using knetworkmanager to connect?

I have found this problem too with Intel 4965 and 2.6.25.16-0.1-default kernel.
Unfortunately your tip doesn’t work for me.
I tried to boot with wireless switch turned on,
then with wireless switch turned off,
but result is the same - wireless card just doesn’t work.

So I guess now I have to upgrade or downgrade
system kernel to get Intel 4965 back to work.

P.S. Strangely enough it worked with the same kernel
quite long period of time (and I use wireless network very often).
So it ceased to work only a couple of days ago,
although I updated kernel maybe month before that.
Probably it is due to the fact that I use s2ram all the time.

After posting previous message in this thread,
I tried to install various kernel versions from different repositories
and rebooted my system about dozen times.
And finally it works again.

However, I suppose just plain kernel update, which I did myself,
will be enough to fix this bug with Intel 4965.
(New version - 2.6.25.18-0.1 has showed up lately in update repository.)

Also I removed compat-wireless-kmp-default package,
though maybe it can be left as is (not sure when I even installed it).