kernel update, grub entry additions, opensuse, kde

Every time I get a kernel update, it adds another entry to the grub menu. I usually just delete the extra entries, if I have a successful boot. Do I need to delete the old kernel directories?

Thanks

You should remove the unwanted kernel versions via YaST or zypper. I find YaST and using the Versions tab the easiest to see what is going on. I tend to keep one previous kernel just in case. :slight_smile:

removing the old kernel will remove it from the grub menu also. Once you are satisfied with the new kernel just go into Yast and remove the old kernel

I have the same question and I am new to Linux and Suse 12.3. I cannot find any option in Yast under the boot loader options to allow me to delete an entry? Where would I look please?

You would use YaST->Software Management for that.
Just search for the kernel package, select it and click on “Versions” in the lower right of the window.
You can then unselect not-wanted versions there.

On 2013-05-30 00:06, wolfi323 wrote:
>
> yakuzah;2561166 Wrote:
>> I have the same question and I am new to Linux and Suse 12.3. I cannot
>> find any option in Yast under the boot loader options to allow me to
>> delete an entry? Where would I look please?
>
> You would use YaST->Software Management for that.
> Just search for the kernel package, select it and click on “Versions”
> in the lower right of the window.
> You can then unselect not-wanted versions there.

You should have two kernels after an update, the third one is
automatically removed. And it is a good thing to have those two, in case
of problems with updates.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Not on my standard 12.3 installation. It depends on how many you have going into the update. I had two remaining from the first kernel update, so after the recent update, I had three kernels remaining after the required system restart. I used YaST Software Management to verify that number, and then removed the earliest, leaving two kernels installed.

There was something wrong with systemd’s default settings, so purge-kernels.service, which is supposed to remove the unneeded kernels, wasn’t enabled by default.

You can also remove them by calling “/sbin/purge-kernels” as root, this respects your settings in /etc/zypper/zypp.conf regarding multiversion kernels.

On 2013-05-30 01:46, consused wrote:
>
> robin_listas;2561181 Wrote:
>> You should have two kernels after an update, the third one is
>> automatically removed.

> Not on my standard 12.3 installation. It depends on how many you have
> going into the update. I had two remaining from the first kernel update,
> so after the recent update, I had three kernels remaining after the
> required system restart. I used YaST Software Management to verify that
> number, and then removed the earliest, leaving two kernels installed.

I get only two:


eleanor3:~ # rpm -qa | grep -i kernel
kernel-desktop-3.7.10-1.11.1.x86_64
kernel-desktop-3.7.10-1.4.1.x86_64
eleanor3:~ #

I saw a message on boot about clearing an older version, it was not me.
Look, from syslog:


> <1.5> 2013-05-29 17:16:09 eleanor3 os-prober - - -  debug: running /usr/lib/os-probes/mounted/90solaris on mounted /dev/sda9
> <3.6> 2013-05-29 17:16:09 eleanor3 purge-kernels 660 - -  Removed:
> <3.6> 2013-05-29 17:16:09 eleanor3 purge-kernels 660 - -  kernel-desktop-3.7.10-1.1.1.x86_64
> <3.6> 2013-05-29 17:16:09 eleanor3 systemd 1 - -  Started Purge old kernels.


Apparently, it runs on every boot, I see more entries in the log.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-05-30 01:56, wolfi323 wrote:

> There was something wrong with systemd’s default settings, so
> purge-kernels.service, which is supposed to remove the unneeded kernels,
> wasn’t enabled by default.

Oh. It is enabled by default on my test system, there must have been an
update.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I get those same two kernels plus kernel-firmware (don’t you have it?) with that command. The other and older version I removed with YaST soon after today’s update and restart.

I saw a message on boot about clearing an older version, it was not me.
Look, from syslog:…

Is that /var/log/boot.log? If so, I see no such messages here. If not the right log, please provide full path and filename.

On 2013-05-30 04:06, consused wrote:
>
> robin_listas;2561204 Wrote:
>>
> I get those same two kernels plus kernel-firmware (don’t you have it?)

No, I don’t. It is a virtual machine.

> with that command. The other and older version I removed with YaST soon
> after today’s update and restart.
>
>> I saw a message on boot about clearing an older version, it was not me.
>> Look, from syslog:…
>>
> Is that /var/log/boot.log? If so, I see no such messages here. If not
> the right log, please provide full path and filename.

Well, the exact place depends on your configuration, it is the “syslog”.
By default, most of it will be on the file “/var/log/messsages”, but
there is another for the mail, another for news, another for the
firewall, etc.

No, /var/log/boot.log does not exist with systemd, only with systemv.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Yes, this was fixed by an update 2 weeks ago:
https://bugzilla.novell.com/show_bug.cgi?id=818317

wolfi323 wrote:

>
> consused;2561196 Wrote:
>> Not on my standard 12.3 installation. It depends on how many you have
>> going into the update. I had two remaining from the first kernel
>> update,
>> so after the recent update, I had three kernels remaining after the
>> required system restart. I used YaST Software Management to verify
>> that number, and then removed the earliest, leaving two kernels
>> installed.
> There was something wrong with systemd’s default settings, so
> purge-kernels.service, which is supposed to remove the unneeded
> kernels, wasn’t enabled by default.
>
> You can also remove them by calling “/sbin/purge-kernels” as root,
> this respects your settings in /etc/zypper/zypp.conf regarding
> multiversion kernels.
>
I’m having start up problems also. Will post seperate thread. But have
question now on /etc/zypper. I do not have a zypper in etc. Seach finds
it in /usr/share/. There is a zypper conf in /etc/zypp. Is this a change
also.

Thanks

openSUSE 12.3(Linux 3.7.10-1.4-desktop x86_64)|KDE 4.10.3
“release 563”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS(NVIDIA-Linux-x86_64-319.17)

On 2013-05-30 11:36, wolfi323 wrote:
>
> robin_listas;2561205 Wrote:
>> On 2013-05-30 01:56, wolfi323 wrote:
>>
>>> There was something wrong with systemd’s default settings, so
>>> purge-kernels.service, which is supposed to remove the unneeded kernels,
>>> wasn’t enabled by default.
>>
>> Oh. It is enabled by default on my test system, there must have been an
>> update.
>>
> Yes, this was fixed by an update 2 weeks ago:
> https://bugzilla.novell.com/show_bug.cgi?id=818317

Just in time for the kernel update…


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-05-30 12:23, Upscope wrote:
> I’m having start up problems also. Will post seperate thread. But have
> question now on /etc/zypper. I do not have a zypper in etc. Seach finds
> it in /usr/share/. There is a zypper conf in /etc/zypp. Is this a change
> also.

There is no “/etc/zypper” directory, there is a “/etc/zypp/” one. As
always, no change.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Yes. Sorry, that was a typo.:shame:

The directory is still called /etc/zypp/ and that config is in /etc/zypp/zypp.conf…

Aha, I decided 12.3 was too experimental (systemd, grub2, etc) and rushed out to meet GA deadline with last minute changes. It’s only in “real” test here as a multi-boot with other o’SUSE and Win7, and I’m now regretting not using a VM. I haven’t had problems multi-booting with “real” kernel updates in years, until 12.3 it seems…

Hmm, I have a /var/log/boot.log, not long with odd characters beginning each line, whereas latest /var/log/messages is not a text file. Your remarks strongly suggest my 12.3 switched from systemd to systemv, since the boot is now displaying detailed console messages since a kernel update. I haven’t manually changed back to systemv, but had a grub2 issue post kernel updating. The fix for that, only included a partition boot flag change and running YaST Boot Loader config with no parameter changes.

Re the number of kernels, I’m posting this from main 12.2 system, so will switch and post back here with two relevant multiversion lines from /etc/zypp/zypp.conf. At least then we can clarify [for me] what they should mean. :slight_smile:

wolfi323 wrote:

>
> robin_listas;2561296 Wrote:
>> On 2013-05-30 12:23, Upscope wrote:
>> > I’m having start up problems also. Will post seperate thread. But
>> have
>> > question now on /etc/zypper. I do not have a zypper in etc. Seach
>> finds
>> > it in /usr/share/. There is a zypper conf in /etc/zypp. Is this a
>> change
>> > also.
>>
>> There is no “/etc/zypper” directory, there is a “/etc/zypp/” one. As
>> always, no change.
>>
> Yes. Sorry, that was a typo.:shame:
>
> The directory is still called /etc/zypp/ and that config is in
> /etc/zypp/zypp.conf…
>
Thought I was dreaming.

Thanks.
Russ


openSUSE 12.3(Linux 3.7.10-1.4-desktop x86_64)|KDE 4.10.3
“release 563”|Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce
8400GS(NVIDIA-Linux-x86_64-319.17)

On 2013-05-30 14:06, consused wrote:

> Aha, I decided 12.3 was too experimental (systemd, grub2, etc) and
> rushed out to meet GA deadline with last minute changes. It’s only in
> “real” test here as a multi-boot with other o’SUSE and Win7, and I’m now
> regretting not using a VM. I haven’t had problems multi-booting with
> “real” kernel updates in years, until now it seems…

I have no alternative, 12.1 will be EOL perhaps in days.

> robin_listas Wrote:

>> By default, most of it will be on the file “/var/log/messsages”, but
>> there is another for the mail, another for news, another for the
>> firewall, etc.
>>
>> No, /var/log/boot.log does not exist with systemd, only with systemv.
>
> Hmm, I have a /var/log/boot.log, not long with odd characters beginning
> each line, whereas latest /var/log/messages is not a text file.

Not a text file? That’s not possible, it has not changed. It MUST be a
text file in any case, systemd or not.

You may have some other problem.

> Re the number of kernels, I’m posting this from main 12.2 system, so
> will switch and post back here with two relevant multiversion lines from
> /etc/zypp/zypp.conf. At least then we can clarify [for me] what they
> should mean. :slight_smile:

You should be able to read the config from your other system without
reboot. I can.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)