Kernel Update: 3.4.11-2.16

Updated the Kernel on 2 machines 3.4.11-2.16

Just to let you know it went well.

One Intel machine
One nVidia

Did it really fix login screen corruption with KMS+plymouth splash screen?

I have not had that anyway

I updated the kernel to 3.4.11 on opensuse 12.2 and now grub doesn’t show any entries, just a black screen with: " grub_ ". I’m guessing it’s a grub2 problem, how do I fix it?

http://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html

If you don’t have the DVD
You can do the same by booting a live cd to a live desktop, open a terminal as su -
And follow the guide above

I did that but now it loads the kernel before the update: “error: file /boot/vmlinuz-3.4-2.10-desktop not found”

So you need to run

grub2-mkconfig -o /boot/grub2/grub.cfg

when chroot

All done, thanks.
But grub2 just makes me uneasy.

I take that to understand you have fixed it?

Yes, some are finding Grub 2 tricky
So far I’m OK with it

@ntasos It seems that you had grub (not grub2) before which explains why grub.cfg was not updated. Then you reinstalled grub2 and had stale grub.cfg. Now you have inconsistent configuration - system tools believe you have grub as bootloader and will try to update its configuration in the future, but you have replaced it with grub2. I would go in YaST2 and check what it thinks about current bootloader and reinstall if there is mismatch.

@caf4926 may be your article needs some words about it. Many people will update from previous versions retaining grub legacy; if they ever need to recover grub2 they fall in the same trap.

Yes, everything work fine.
Although when I rebooted the entry for the windows partition had disappeared but I enter Yast and I checked bootloader to boot from root partition and now everything works.

So this was a grub related problem?

It’s grub related yes.
But the details will vary with each users setup

I did a clean install of 12.2 so grub was not messed up and i believe I entered yast before and grub2 was listed as the bootloader.
Maybe it’s something I did, but for now nothing seems wrong

Well
Perhaps make a note of my fix method for future ref
Happy you sorted it

Did you configure zypper to keep multiple kernels (“multiversion” parameter in /etc/zypp/zypp.conf)?

There is a line inside zypp.conf: “# multiversion = provides:multiversion(kernel)”
This means it keeps multiple kernels?

when i upgraded from 3.4.6-2 to 3.4.11-2 and rebooted it began to say it couldn’t extract something ,went into panic mode each time i restarted
second mode or safe boot also did not help
Had to reinstall the entire OS :frowning:
Please guide me to a link which has details about keeping multiple kernel versions
I don’t want to upgrade again and lose my OS

  • did the update:

  • rebooted, back in desktop, 3.4.11, no sound, no network

  • rebooted, back in desktop all was fine but for some reason I had 3.4.6 back

  • rebooted, back in desktop, 3.4.11, all was working well

  • by now I was more then puzzled as I don’t have the opntion for multiple kernels

  • did an init 3, then nvidia drivers hard way, got message that /usr/src/linux/include/version.h did not exist

  • did yast from command prompt downgraded to 3.4.6

  • rebooted, back in desktop, 3.4.6 but no sound and no network

  • I tried a few more things but could not get a stable system anymore

  • ended up doing a re-install of / only, upgraded to 3.6.11 after that and all was well

  • only thing that did not work was de default 3.12.4 version of hplip no longer worked, but upgrade in Index of /repositories/Printing/openSUSE_12.2 solved that.

all in all not a smooth update, but got no idea what went wrong to be honest, just a big angry at myself that my / backup was to old.

Booted it, seems fine. Will keep it as a backup in case something goes wrong, running 3.6.1-1-desktop on 12.2 at the moment.

Had to reinstall the entire OS :frowning:

If you have the DVD, you can repair the install