Kernel update 2.6.27 disables UVC webcam?

My webcam worked fine with 11.1. Yesterday, updated the kernel to 2.6.27, which deinstalled the uvcvideo-kmp-default, which I accepted, since afaik this is now included in the kernel since 2.6.26 (Kernel Log, heise.de, german)](http://www.heise.de/open/Viel-bewegt-Die-Neuerungen-von-Linux-2-6-27--/artikel/116387).

Nevertheless, my webcam (0xc45:0x63f8) does not work anymore. :frowning:

Any ideas why and how to fix this, except for downgrading the kernel again?
(Downgrading via Yast does not seem to work, since the Nvidia- and Alsa-driver modules seem to be unavailable now in the required older versions! :frowning: )

Could it be that the integrated UVC module is older than the external module?

Mmm, strange I have the latest kernel offered for openSUSE 11.1


$ uname -a
Linux suse 2.6.27.19-3.2-pae #1 SMP 2009-02-25 15:40:44 +0100 i686 athlon i386 GNU/Linux

And I don’t have that problem. There is a way to fix it though. First, go here: ~pinchartl/uvcvideo: Summary](http://linuxtv.org/hg/~pinchartl/uvcvideo/)

Click on either the bz2 or the gz link (whichever you prefer). Download it and put it in the folder of your liking. Then, in the konsole /terminal do:


cd folder/
tar xvfz uvcvideo****.tar.gz
cd uvcvideo****
./configure
make
sudo make install
make clean

if configure spits out errors, you have to try to get the packages it requires to be compiled. Make and Make install will take a while, so be patient. I apologize in advance because there’s been some time since I’ve done this and I’m unsure if the ./configure line is required, but try it, nonetheless and report back if you have trouble.

Once you are done, restart your computer and try plugging in the webcam and try again. Hopefully this will work well.

It installed without trouble, but did not change anything at all:

  • gqcam correctly identifies the camera, but continuously prints “error reading image” to standard out.

  • camorama aborts immediately.

  • skype does not register any video device.

All three worked out of the box before YaST Online Update (which did fix other things though).

There is no configure script in the packet, but make and make install went through fine (once I had the kernel sources installed with YaST).

> uname -a
Linux mara 2.6.27.19-3.2-default #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux

mmm…I was sure that would work…

Do this and show me the output:


lsmod | grep uvc

Also, try installing luvcview:


sudo zypper install luvcview

It’s a lightweight program that works well with UVC video webcams. If it still doesn’t work, I honestly don’t know what to do…


> lsmod | grep uvc
uvcvideo               59860  0
videodev               41808  1 uvcvideo
v4l1_compat            13836  2 uvcvideo,videodev
usbcore               195904  5 uvcvideo,usbhid,ehci_hcd,uhci_hcd

Interestingly enough, luvcview activates the built-in webcam and displays the picture just fine! :slight_smile: Thanks!

So that means something else got messed up, causing all the other programs to fail to detect a working camera. :frowning: Any Ideas?

Your problem is strange. But I do suffer from something similar, in a way. In my case, ekiga always refuses to work with the camera (though I’ve been told this is fixed in a new version not yet incorporated to 11.1). When I get the latest updates for gstreamer from packman, cheese also stops working. Luvcview, however, seems to be immune to this, that is why a prefer it over all, even though it’s so simple. However, in my case, skype does detect the webcam and I’m able to use it perfectly. So what really happens to you in skype? if you go to options > video settings can you not select your camera from the list and test it?

I don’t really know what could possibly be wrong. Try reinstalling the programs that stopped working with the webcam to see if they are able to see that you installed the latest drivers for the uvc camera.

If this doesn’t work, let me know

No, the drop-down list contains only one element “No devices found”. I reinstalled it, as well as the other software.

Well, maybe I reinstall the entire thing anew, for there are other things that are different compare to another machine that I installed later.

I have a similar problem,
before when I launched luvcview everything worked well, now:’(

pla@dellino:~> luvcview
luvcview 0.2.4

SDL information:
Video driver: x11
A window manager is available
Device information:
Device path: /dev/video0
ERROR opening V4L interface: No such file or directory
pla@dellino:~>

and dmesg give this

dellino:~ # dmesg | grep uvc
uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to query (129) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
dellino:~ #

could it be because update of kernel?? or other ideas?

The YastOnlineUpdate providing the kernel update definitely was the source of the problem for me.

There does not seem to be a fix in sight, other than rolling back 11.1 as delivered. :frowning:

Hi.

I have managed to start my uvc camera by “kopeta”, if open config in it and check a camera, it starts to be visible in skype.

But, when I unplug camera from usb “uvcdynctrl” takes 100% CPU usage and HDD begins constantly do something (indicator shows permanent activity). I can kill uvcdynctrl, but what to do with HDD activity. I did reboot - but it is not a solution.

Thank you.