Kernel sources for virtualbox

Hi!
I have suse11 and I install virtualbox but… I can’t it run because I don’t have the kernel sources… so… how can I install them? (in my last distro I installed from console with command: urpmi kernel-sources).
I have kernel 2.6.25-5.1… and I found kernel sources 2.6.25.11-1 or something…

tk

Goto yast>software management and search kernel-headers. Click on the box at the left of the name of the package you want to install and accept

I installed VirtualBox last week and had to go to Install Software and searched kernel-source. The package was there and VirtualBox worked after installing. I also had to install Make to get the vbox-driver to work.

Ok! thank’s… stay tuned… I will try and post the results…:smiley:

nope! doesn’t work…:mad: I have installed Make, kernel-headers, kernel-sources for nothing… I have tried vbox from repo and sun site… same thing… now I have kernel 2.6.25.11-1.1, 2.6.25.11-1.1-pae, 2.6…-debug…:frowning:

all u need is “make”, “gcc”, “kernel-source”

:slight_smile: … I have… I’ll try to install gcc again…

it would be helpful you included error messages or logs:

are you using this repo
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

or the non-oss version

Sorry, I forgot about gcc.

I will post snapshots and console error… especially that repo I don’t have … I have oficial repositories (oss, non-oss, update, src-oss, src-non-oss, !!debug!!!, packman, nvidia)

that repo I don’t have

it’s from the build service, I use it and it’s a dream

check here for help too
VirtualBox Installation - openSUSE

i can’t insert snapshots so…

this is from VM:

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv 
was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' 
as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


Result Code: 
0x80004005
Component: 
Console
Interface: 
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

and from console after…" /etc/init.d/vdoxdrv " setup command…

bodo:~ # /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module                                    done
Recompiling VirtualBox kernel module, NOT. It has been packaged.     done
Starting VirtualBox kernel module                                    failed
  (No suitable module for running kernel found)

uname -a:
Linux bodo 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 i686 athlon i386 GNU/Linux

I have
kernel-default 2.6.25.11-0.1
kernel-debug 2.6.25.11-0.1
kernel-pae 2.6.25.11-0.1
virtualbox-ose-kmp-default 1.6.2-2.6.25.11-0.1-2.10
virtualbox-ose-kmp-pae 1.6.2-2.6.25.11-0.1-2.10

if there is a catch…
now I have installed *.rpm virtualbox from sun site…

you have this - why? You are AMD
or is this needed because you have 4G RAM? (I’m not sure)?

kernel-pae - Kernel with PAE Support
This kernel supports up to 64GB of main memory. It requires Physical Addressing Extensions (PAE), which were introduced with the Pentium Pro processor.

The rpm from Sun is free for Private use and has USB support too.
Have you managed to sort it then?

I had the exact same problem as you yesterday. Take a look at this website the solution worked for me :slight_smile:
Slax forum: VirtualBox Problem

Cheers,
Tom