kernel sources different than kernel ?


I’m trying to update kernel as I have this system lockup problem with kernel.

There is new kernel in opensuse factory ( but kernel-sources are

I need sources to install nvidia drivers.

Can I use that different source to compile nvidia drivers? Or can I get matching sources from somewhere?

Or is there better “stable” kernel available?

Those kernel RPMs are less than a day old. Maybe the mirrors haven’t caught up with the latest kernel-source RPM yet. Wait a bit and try again.

There is still no change.
I think it is some kind of mistake?

You quote Factory and Stable in the same breath. Why have you moved from the default oss?

File a bug report then. The kernel-sources package seems to be 3 days behind.

Because I have lockup symptom with stock ( kernel. I just want to update kernel to get rid of this problem.

Sorry, I’m quite newbie… what is correct place to report a bug?

Ok, there is still no recent kernel sources.
Can I use this quide to build my custom kernel:
Configure, Build and Install a Custom Linux Kernel - openSUSE

I’d like to install latest available sources with yast and the build corresponding kernel version. I think that is ok? Guide however says that I need to have same latest kernel version running than I want to compile:

Configure, Build and Install a Custom Linux Kernel - openSUSE

But this is of cource impossible. Can I still do this safely?

The 2.6.29-1.2 kernel with sources is in Factory now, available through YaST. For a reason I can’t explain, there are also rpm’s for including sources but these do not show up in YaST.