Kernel repository and updater applet

I’m not sure if this is the right forum for this post, so please correct me if I’m wrong.

I’m running openSUSE 11.2, but have changed my kernel to use the Kernel-repo from obs, and x server from XOrg-repo to get KMS for my Ati Radeon HD 4670

Now, the problem is that the updater-applet (kde) is reporting a patch for my kernel (Linux kernel: security and bugfix update - new version 2146). The updater doesn’t seem to do anything when I try to install this update, and I don’t get any errors. But as soon as it’s done, it tells me that it still needs to add this patch. (I’ve tried to do this trough the yast updater as well, and get the same result.)

I believe that this is because the updater applet is trying to patch the oss-repo kernel version, but can’t find it. What can i do to get rid of this problem?

paste here output of this command:

zypper -v dup

Not sure if this is any help, but here go:
(I don’t want to downgrade/change vendor on all those packages, so i pressed N in the end :slight_smile: )

:: root@linux-l0ba:. > zypper -v dup
Verbosity: 1                        
Initializing Target                 
Checking whether to refresh metadata for Games
Retrieving: repomd.xml [done (0 B/s)]         
Retrieving: repomd.xml [done]                 
Retrieving: repomd.xml.asc [done]             
Retrieving: repomd.xml.key [done]             
Retrieving: repomd.xml [done]                 
New repository or package signing key received:
Key ID: 5FEE281C53A2E3F5                       
Key Name: games OBS Project <games@build.opensuse.org>
Key Fingerprint: 8DD093399A1D85972CAD53265FEE281C53A2E3F5
Repository: Games                                        

Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?] (r): a
Retrieving: primary.xml.gz [done]                                                  
Retrieving repository 'Games' metadata [done]                                      
Building repository 'Games' cache [done]                                           
Checking whether to refresh metadata for Kernel                                    
Retrieving: repomd.xml [done]                                                      
Checking whether to refresh metadata for XOrg                                      
Retrieving: repomd.xml [done]                                                      
Checking whether to refresh metadata for jobermayr                                 
Retrieving: repomd.xml [done]                                                      
Checking whether to refresh metadata for openSUSE-11.2-Non-Oss                     
Retrieving: content [done (0 B/s)]                                                 
Retrieving: media [done]                                                           
Checking whether to refresh metadata for openSUSE-11.2-Oss                         
Retrieving: content [done (563 B/s)]                                               
Retrieving: media [done]                                                           
Checking whether to refresh metadata for openSUSE-11.2-Update                      
Retrieving: repomd.xml [done]                                                      
Retrieving: repomd.xml [done]                                                      
Retrieving: repomd.xml.asc [done]                                                  
Retrieving: repomd.xml.key [done]                                                  
Retrieving: repomd.xml [done]                                                      
Retrieving: e3044ee5780f189a8b5948575967c0cfef32a279-susedata.xml.gz [done (25.8 KiB/s)]
Retrieving: dc13d2c3134583ca6bb4881477b1f252d82049bb-updateinfo.xml.gz [done]           
Retrieving: 62383152be983c520d45b898680c1a5b023d4acd-deltainfo.xml.gz [done (214.8 KiB/s)]
Retrieving: e18764580c0b7368f839f9f680a7b406a6a97efd-primary.xml.gz [done (422.4 KiB/s)]  
Retrieving repository 'openSUSE-11.2-Update' metadata [done]                              
Building repository 'openSUSE-11.2-Update' cache [done]                                   
Loading repository data...                                                                
Reading installed packages...                                                             
Computing distribution upgrade...                                                         
Force resolution: No                                                                      
Computing upgrade...                                                                      

The following NEW packages are going to be installed:
  libblas3       3.2.1-2.2                           
  libgfortran44  4.4.1_20090817-2.3.4                
  liblapack3     3.2.1-2.2                           


The following packages are going to be REMOVED:
  kaffeine-lang     0.9+1.0pre3-0.pm.2.1       
  libv4l1-0         0.6.4-1.pm.5.1             
  libv4l2-0         0.6.4-1.pm.5.1             
  libv4lconvert0    0.6.4-1.pm.5.1             
  libxine1-codecs   1.1.18.1-1.pm.37.2         
  virtuoso-drivers  6.1.0-4.1                  
  virtuoso-server   6.1.0-4.1                  


The following packages are going to be upgraded:
  apparmor-parser                         2.3.1-11.12.1 -> 2.3.1-11.13.1                            
  apparmor-utils                          2.3.1-12.2 -> 2.3.1-12.3.1                                
  drm-all-kmp-default                     20100401_2.6.34.0_rc3_7-2.1 -> 20100405_2.6.34.0_rc3_7-1.1
  drm-all-kmp-desktop                     20100401_2.6.34.0_rc3_7-2.1 -> 20100405_2.6.34.0_rc3_7-1.1
  kernel-debug-base                       2.6.31.12-0.1.1 -> 2.6.34-rc3.7.1 
                        
(AND LOTS MORE)


The following packages are going to be downgraded:
  cvs                                   1.12.12-158.1 -> 1.12.12-155.2            
  cvsps                                 2.1-166.1 -> 2.1-164.1                    
  git                                   1.7.0.2-1.1 -> 1.6.4.2-3.3                

(AND LOTS MORE)


The following product is going to be reinstalled:
  openSUSE  11.2-0


The following packages are going to change vendor:
  gstreamer-0_10                    0.10.28-999.pm.1000.1 -> 0.10.24-3.1                http://packman.links2linux.de -> openSUSE
  gstreamer-0_10-lang               0.10.28-999.pm.1000.1 -> 0.10.24-3.1                http://packman.links2linux.de -> openSUSE
  gstreamer-0_10-plugins-base       0.10.28-999.pm.999.3 -> 0.10.24-2.4                 http://packman.links2linux.de -> openSUSE
  gstreamer-0_10-plugins-base-lang  0.10.28-999.pm.999.3 -> 0.10.24-2.4                 http://packman.links2linux.de -> openSUSE

(AND LOTS MORE)


162 packages to upgrade, 75 to downgrade, 3 new, 7 to remove, 52  to change vendor.
Overall download size: 188.0 MiB. After the operation, additional 2.0 MiB will be used.
Continue? [y/n/?] (y): n

Had to crop the pasted text to post it here, just ask, and I will try to post it again.

Maybe do update a then refresh updater applet solves your problem:

zypper up

This will not downgrade any packages.