kernel panics on new AMD processor

Hi Guys

I just purchased an AMD Phenom 9850 processor with a Gigabyte GA-MA790FX-DQ6 motherboard.

I have downloaded Opensuse 11.0 to install on my new setup. After i get the Welcome screen and i select Installation, OpenSuse loads the kernel and then i get kernel panics. I am trying to install on an IDE drive that had 10.3 installed on it. I have not managed to get a screen shot and will take a pic of the Kernel Panic error, which is the same as this one: [Phoronix] AMD Phenom 9500 Linux Performance (Spider Platform) Review](

I also tried to boot from the LiveCD and got as far as Starting HALDaemon and the machine froze. From the previous website, i understand that there may be some inconsistancies with the AMD processors. Is there anyone that might be able to shed some light and maybe point me in a direction?

Kind regards


PS. I am trying to install the 64 bit software. Will try to download the 32 bit ver and see if that helps. Also tried to install OS 10.3 on it, but had no luck there.

at the screen installation, you have place to said no acpi and thing like that…

you can check there…

You do probably need some kernel boot parameters. On the installation menu, did you try (under F5) the safe settings, no acpi, and no lapci options?