Kernel Panic-- openSUSE 11.1 installation failed

I’m using openSUSE 11. I’hv tried to upgrade it to 11.1 with a x86_64 installation DVD (as I did earlier), but it failed.
It showed the following message:

…failed :frowning:
Kernel panic - not syncing:IO-APIC + timer doesn’t work!
Boot with apic=debug and send a report. Then try booting with ‘noapic’ option.
----[cut here]-----
warning: at kernel/smp.c331
smp_call_function_musk+0x38/0x1f2()
Modules linked in:
supported:yes
Pin:1, comm: swapper Not tained 2.6.27.7-9-default#1
Call Trace:
<ffffffff8020e42e>]show_trace_log_lvl + 0x41/0x58
<fff… >] dump_stack + 0x69/0x58
<fff… >] warn_on_slowpath +0x51/0x77
.
.
.
<fff… >] child_rip+0xa/0x11
–[end trace 4eaa2a86a8e2da22]–

eventually same type of problem happend when I was trying with fedora 10… fedora 9 and openSUSE 11 install smoothly in my 64 bit machine (compaq SR1730IL, Intel pentium 4, 524 and 1GB DDR2 RAM)
Please please please help me!!!
:’( :’( :’(

Try booting with the noapic option, as suggested.

Here is an explanation for Ubuntu, I think this should be the same for OpenSUSE:

How to add noapic to grub? - LinuxQuestions.org

On the DVD intall CD, there’s a Kernel menu F4 or F5 I think.

In it there’s a “No Local Apic” option, along with “Safe Mode” and an option to disable ACPI.

Or you can type, in the input window as the panic, report told you to do :

boot : noapic

If you do this for the installer boot, the command will be written into your GRUB config file later, by the installer, so you shouldn’t need to redo it.

Actually, when the problem is eventually fixed upstream, you’ld want to remove it.

Good luck!

very very sorry for late reply!

Thanks a lot. Your procedure help me that time.
I started my journey to linux world through opensuse 10.1… now using 11.2.
Through these years with opensuse i learned lots of things on linux and now proud to be an experienced user, but learning never stops. Each day is a new day to explore the infinite knowledge bases!

Again thanks a lot! :slight_smile:

saptarshi wrote:
> very very sorry for late reply!

heh…better late than never!
-=welcome=- back…

drop in more often, there are a lot of new faces everyday, asking
questions you now know the answer to!


palladium

I will do. Thanks. :slight_smile: