Kernel panic on media check with latest tumbleweed snapshot

I’m interested in using tumbleweed on my primary work machine - a 2015 dell xps 13 (9343). Currently I’m using an arch-based distro, and so I used suse image writer (which is available on the AUR) and burned the current net install iso (snapshot 12/10) to a usb stick. I know that this was successful, since I ran a media check, and successfully installed tumbleweed on an acer aspire 5750g using this usb stick subsequently. However, when I run a media check with this same usb stick on the xps 13 the result is a kernel panic, and I have to do a hard reboot. I’ve tried re-writing the image onto the usb stick, trying the live and dvd images, and even trying opensuse instead of tumbleweed, but the result seems to be consistently that a suse-based iso refuses to work on the xps 13. This is disappointing, since I’ve managed to boot into a live environment with the most recent fedora and ubuntu releases on this same machine, using the same usb stick, and generally this is the only distro that i’ve had a big problem with.

This is a real shame, since I’m having a great time using tumbleweed on the aspire 5750g. I was wondering if anybody else has encountered similar issues on the xps 13, and/or if anyone has any advice on how to debug this.

Thanks in advance for your help!

I am typing this on a xps 13 9343. I installed leap without any issues. I’m not using tumbleweed. Feel free to hit me up if you need any help.