Kernel Panic and Caps lock Blinking on Dell XPS 13 9343


I’m experiencing randomly system crashes with Opensuse Leap 42.1 installed on a Dell XPS 9343. Before this, I was using Opensuse 13.2 without problems. My first thought was it had a hardware malfunction. I run Dell diagnosis tests (including on new dell computers), including extended memory tests and everything was OK. So, I think it is a software related problem.

The system crashes totally randomly and I have no idea what kind of problem could be. One fact is that I always use the computer with an extended monitor connected through HDMI. This crashes happened with this configuration but I can’t completely assure this since I barely use the laptop without an extended display. I also use a wireless mouse and keyboard Logitech K330.

The system is up to date, with kernel 4.1.20.

Any help will be appreciated.

Thanks in advance.

Last night I run memtest86 tests in order to discard the chance of a hardware problem. All test passed. Any suggestion?

Hello Rifle,

sorry I do not have an answer, but rather a question, I am planning to get rid of ubuntu on the XPS, are there any big issues using opensuse?
Are there things that do not work (e.g. screen brightness control, sound, bluetooth…).

Thanks in advance for your answer.


I would consider downloading the DVD ISO for Tumbleweed.
One of our developers has Tumbleweed installed as it provides the latest kernel and drivers.

For bluetooth don’t forget to install “rfkill” to unblock the software for your bluetooth.