kernel NFS worked. Set up BIND. Now BIND works, NFS doesn't.

I decided to set up BIND following this tutorial and it works, but other things have stopped working.

Here’s a simplified version of the dns table:

pittsburg     IN A     192.168.1.1
ns1           IN NS    pittsburg
hershey       IN A     192.168.1.2
newton        IN A     192.168.1.3
  1. If I send a dig question to ns1 (me@anybox:$ dig @192.168.1.1 hershey.local.network), it returns the appropriate answer.

  2. If I ask a dig question without specifying the server (me@anybox:$ dig hershey.local.network), I get a servfail.

  3. I have NFS network shares on pittsburg, which as you’ll recall, is also ns1. Clients can no longer connect:

niels@hershey:~$ sudo mount -rw pittsburg:/music /mnt/music
mount.nfs: server does not recognize hostname

(or something like that. The meaning is there, the words I forget, and I’ve further botched it since by setting up hershey as a secondary dns server, so I’m having a hard time even recreating that error :-p Here’s the new error, running both machines as DNS servers:


niels@hershey:/$ sudo mount -rw pittsburg:/music /mnt/music
sudo: unable to resolve host hershey
mount.nfs: can't get address for pittsburg
  1. SSH works in some cases, but not others:
from        to           works?
hershey     pittsburg    yes
hershey     hershey      yes
hershey     newton       yes
newton      pittsburg    yes
newton      hershey      yes
newton      newton       yes
pittsburg   pittsburg    no
pittsburg   192.168.1.1  yes
pittsburg   hershey      no
pittsburg   192.168.1.2  yes
pittsburg   newton       no
pittsburg   192.168.1.3  yes

Any thoughts?

I solved one problem in the above post by uninstalling bind on the machine I’d tried to set up a secondary DNS server on. So I can positively state the NFS error I get is


niels@hershey:/$ sudo mount -rw pittsburg:/music /mnt/music
mount.nfs: access denied by server while mounting hershey.penn.sylvania:/music

Ah, so, turns out I needed to specify 127.0.0.1 as a name server on my interface. So . . . in addition to the tutorial, one needs to go YaST → Network Devices → Network Settings → Hostname/DNS → Name Server 1 (or 2 or 3) and change it to 127.0.0.1.

Solved most of my problems, then it was all a matter of flushing cache on the other computers.