Kernel-firmware update 20181026-lp150.2.6.1 locks up system

I updated my system last night, which included a kernel firmware update. This morning, my system wouldn’t boot, it just hung on the boot splash screen. Pressing esc did not show any messages. At the time I wasn’t sure which update caused it so I did a rollback, rebooted and tried the update again. Same problem. Anyone else having a problem with this update making their system unbootable?

If I lock the firmware version in yast, do I also need to lock the kernel version?

Thanks.

https://bugzilla.opensuse.org/show_bug.cgi?id=1121715
https://bugzilla.suse.com/show_bug.cgi?id=1121714

Atheros (ath10k_pci) Wlan?

/sbin/lspci -nnk | grep -iA3 net

At least, in theory, that should not be needed.

A package normally lists its requirements. And if a kernel update requires a newer firmware, but you have locked the firmware against updating, then that should also block the kernel update. You might get a “conflict resolution dialog” if you use “Yast” or “zypper” to update – that would give you a choice between skipping the kernel update or updating the firmware anyway (bypassing your lock). If you use the desktop update applet, it probably doesn’t provide a dialog. It might just report a problem and fail to update.

Yep, that’s my wifi card and driver.

I’m experiencing the same problem on my Alienware machine.

I have the same problem.
My Wi-Fi chipset is Killer 1435.

If you installed the root file system with btrfs, you can do a rollback to a snapshot before you installed the update that broke the system. Select boot from a read-only snapshot from the grub2 menu, then select a snapshot from sometime before the update. Once you’re booted into a functional system, in a terminal window enter:

sudo snapper rollback

which will make the booted snapshot the current one. Then reboot the system normally. After that open up a terminal window and enter:

sudo zypper al kernel-firmware

which will lock the firmware version and prevent it from updating. Then you should be able to install the other updates without breaking the system.

If you’re not using btrfs, then reverting back to the old firmware will be a little more tricky, and I’m not exactly sure how to go about that.

I just discovered that the Killer 1435 wlan chip in my notebook is actually a Qualcom Atheros QCA988x chip…

From this thread

https://bugzilla.suse.com/show_bug.cgi?id=1121714
it seems that update “kernel-firmware 20181026” is the culprit.
Fortunately I can switch of wlan in the UEFI and avoid the kernelpanic.
I’ll download manually the older “kernel-firmware 20180525” and install it to see what happens.

http://download.opensuse.org/update/leap/15.0/oss/noarch/kernel-firmware-20180525-lp150.2.3.1.noarch.rpm

I’ll let you know.

I can confirm that the latest kernel-firmware update was the culprit.

Just in case somebody else stumbles over the same problem, here’s how I solved it.

In the UEFI settings I disabled wlan en Bluetooth. That way I was able to boot the system.
Using another computer, I downloaded the old kernel-firmware here:

http://download.opensuse.org/update/leap/15.0/oss/noarch/kernel-firmware-20180525-lp150.2.3.1.noarch.rpm

and I copied it to the notebook using a usb-stick.

Then, on the notebook, in Yast I disinstalled the kernel-firmware.

(At this point, do not switch-off or reboot your notebook. I don’t know what will will happen without the kernel-firmware being present on your system!)

Then, in the console I installed the downloaded rpm using the command “sudo rpm -i kernel-firmware-20180525-lp150.2.3.1.noarch.rpm”

I rebooted, went into the UEFI to enable wlan and Bluetooth and everything worked again.

Regards,

Teuniz

Great.

I suggest you lock the firmware to the version that is working. You can do that in Yast Software Management. Search for the firmware, right click on it and lock it from updates. When you manually force an update, after you hear that the problem is solved, that should clear the lock.

This new kernel also borked my network but system still boots. Acer Laptop with i7-6500u and Nvidia 940MX so it is one of those “infernal optimus” systems we all love so well. This is a snapshot of the hardware id’d via opensuse as an image capture.

https://1drv.ms/u/s!AmldHc9yuYct-2c6Ri302eCQEvGD

I did snapper back and get it running again and then tried to redo the update. Same result. Now I will rollback to the previous kernel until a fix is hopefully found.

Regards,
Bill

Update:

Since it cares not for my image the network adapter is:
Qualcomm Atheros QCA9377 Wireless Network Adapter

The issue is with the kernel-firmware package. After rollback, lock that package and you can install the other updates. AFAIK a fixed package is on the way

Thanks for the update! I have the older kernel loaded and locked for now.

Best Regards,
Bill

Same issue here…
ttps://forums.opensuse.org/showthread.php/534589-After-Leap-15-update-bug-in-kernel-firmware-was-freezing-bootup-process

It would be great, if how you reboot after disabling wlan and bluetooth were explained. My system still locks up during boot. I’m booted now with a rescue DVD and I’ve got the new RPM copied into /usr/src as a temporary stash, but since “/” is actually mounted as “/mnt” in the rescue boot, it is unclear how I can straightforwardly replace the .ko files in /lib/modules/4.12.15-lp159.12.*/kernel/drivers/net/wireless/ath.

What would happen if I simply removed the lp150.12.28 version, leaving lp150.12.25?

This certainly is painful.

Some assumption:

Your rescue DVD is using a 64-bit kernel.

The network is still working in rescue mode.

If those assumptions are correct, then try:


mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
mount --bind /proc /mnt/proc
cp /etc/resolv.conf /mnt/etc/resolv.conf
chroot /mnt
mount -a   ### this should mount anything missing, including btrfs subvolumes
yast

That should give you a command line (ncurses) version of yast. It’s a bit harder to use than the GUI version, but it still works. Use that to install the older firmware version.
Then

exit

That gets you out of the “chroot” environment. Reboot and see if your system now starts properly.

It’s not the kernel, it’s the kernel-firmware package. If you force the install of the DVD version, then reboot you should be back in business. The bug is in the kernel-firmware package, no need to replace the kernel.

Tweaked for paranoia:

Well, it seems the network is not up and the installation of

[FONT=courier new]kernel-firmware-20180525-lp150.2.3.1.noarch.rpm

[/FONT]requires a network. I’ll be back tomorrow. :frowning: