kernel does not generate /proc/asound on boot

I have the kernel 4… I have the newer kernel-firmware.

Still no sound. /proc/asound is still not being loaded.

Is there a reference that explains the files used by the kernel on boot?

So again: How exactly do you boot your openSUSE 13.2 installation from the NET-install CD?

I’d also suggest to try to boot a 13.2 LiveCD and check whether the sound works there.

Oh, and AFAIK, dual boot with Windows 10 should work fine.
What exactly is your problem there?
Although you should better open a new thread about this.

Maybe fixing your dual boot and booting the system “normally” would also fix your sound problem.

Is there a reference that explains the files used by the kernel on boot?

No idea.
What do you want to know exactly?

/proc doesn’t exist on your hard disk, it’s just an interface to the kernel’s internal data structures.
/proc/asound/ will only be created when a sound module (“driver”) is loaded. In your case it should be snd-hda-intel, which cannot be loaded for some reason.

Kernel modules are in /lib/modules/$kernelversion as I wrote already, they are loaded automatically by the kernel if a supported hardware is detected.
Other than that, you can explicitely specify modules to be loaded in /etc/modules-load.d/ and/or /etc/modprobe.d/ where you can also specify options for modules that are loaded.
YaST->Hardware->Sound creates the file /etc/modprobe.d/50-sound.conf to “configure” your sound card. But again, you should have sound even without it.

Found info on module loading and kernel configurations:
http://edoceo.com/howto/kernel-modules
http://praxis.edoceo.com/kernel/dev
http://praxis.edoceo.com/kernel/cfg

Going to explore.