Kernel -desktop vs -default

For reasons concerning my front USB 3 ports that I discuss in another thread[1], I had to switch from a -desktop kernel to a -default kernel. According to the RPM description, the -desktop kernel is tweaked for desktops. This includes lower latency and removing bits that aren’t normally found on a desktop system.

My question is, what can I do to my system’s configuration (e.g. kernel params, /etc/sysconfig, sysctl?, etc.) that could take make -default kernel install perform like a -desktop kernel? The reason I ask is that I have noticed some slow down now that I am using the -default kernel. I do not have any data to support this. It just seems like the boot up takes a little longer and the shutdown takes a little longer. I guess it could all be in my head too.

Anyone know of any any “magical” kernel options I could use? Or perhaps anything I could do via Yast2 (e.g. Yast2->System->Kernel Settings) or some other config file?

[1] https://forums.opensuse.org/english/get-technical-help-here/hardware/480965-usb-ports-not-working.html#post2507157

I have several USB 3 drives and they work with openSUSE 12.2 and the default kernel, but I am not sure how a front mounted USB 3 port would be different. While I have USB 3 working, my PC’s provide only rear mounted USB 3 access. I even requested that the USB 3 driver be included in openSUSE 12.2 by default and have booted openSUSE 12.2 from a USB 3 drive before. I have seen some issues with USB in general that gets messed up by having a USB hub in between the device and the native built-in PC port, but it was not about USB 3 as I remember. Be that as it may, the difference between kernel desktop and default is just its configuration. Generally, desktop leaves out modules mostly needed for servers and while desktop is optimize to give its graphic GUI more CPU and memory resources. The bottom line is you can compile your own kernel and configure it anyway you want if you know what that is. For instance, on my desktops, I set the default CPU speed to the Performance Governor as a Kernel config change. I have a bash script that allows changes to configs, the saving, editing and restoring of any kernel config. Because there are hundreds (thousands?) of kernel configurations, it can be a little time consuming to figure out every little detail without having something you are looking for. Here is my Bash script you must try if you have not already done so.

https://forums.opensuse.org/blogs/jdmcdaniel3/s-k-c-suse-automated-kernel-compiler-version-2-50-34/

Thank You,

The default kernel is compiled with some more conservative values than the desktop one on at least two features. To change those parameters you need to recompile the kernel.
Those features are:

  • Processor type and features:
    • Timer frequency, (set to 300Hz on ‘-default’ and 1000Hz on ‘-desktop’).
    • Preemption model, (set it to the highest option ‘Low latency desktop’.)

If you are unfamiliar with how to compile and customise the kernel I suggest you read about it before you attempt anything. But you might be successful with using the source of the kernel version that worked for you, clone the current running (default) kernel config and modify the parameters which will give you lower latency.

On 11/29/2012 12:06 AM, alvinbeach wrote:
> It just -seems- like the boot up
> takes a little longer and the shutdown takes a little longer.

this is a very simplistic, pragmatic, non-geek way to approach your
‘problem’:

Simply decide which is best for you:

  1. use default kernel and have working front USB ports
    or
  2. switch to desktop kernel so it -seems- to boot/shutdown a little faster
    or
  3. do a lot of hunting and kernel compiling/testing then see if it
    -seems- to boot/shutdown faster (or slower) and if all USB work, or not

i guess i’d choose #1 and maybe close my eyes a few seconds
(microseconds??) during boot/shutdown to stop the apparent passage of time.

ymmv


dd

I tried the -desktop kernel again the the front USB ports still work. Sometimes they work after resuming from sleep too.

I’ve compiled the kernel many times back in the day. I use to have my own script (not as robust as yours though jdmcdaniel3) that would build the kernel and produce RPMs that I could deploy on several machines. IIRC, this was with the 2.2 version and later with the 2.4 version. Back then the goal was to make it as small as possible. Nowadays, I find the -desktop kernel to be perfect. Not exactly small, but certainly fast.

Thanks for the info on the kernel config options!

Happy to hear you are working as you wish. If you have any comments on SAKC, make sure to post in the SAKC bash script blog.

Thank You,

I like the desktop kernel also. The only problem I have with it is autogroups enabled by default which messes with my ability to use priorities/nice. So I just add the boot parameter noautogroup to disable it.

hi!

how to know if I got kernel-**default **or kernel-**desktop **?

tia!

On 2014-03-23 19:46, goro goren wrote:
>
> hi!
>
> how to know if I got kernel-*default *or kernel-*desktop *?

uname -a


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

If you did nothing special to install it you should have desktop. You can also look in Yast-software management and search for kernel and see what you have installed.

~> uname -r
3.13.6-19.g4727218-default

I’d prefer use **kernel-desktop…

:nerd:
**

On 03/23/2014 06:46 PM, goro goren wrote:
>
> Code:
> --------------------
> ~> uname -r
> 3.13.6-19.g4727218-default
> --------------------
>
>

Then choose it. You do realize that you are the one that picked that kernel. The
default is desktop.

Except for 32bit non-PAE CPUs of course. :wink:

You wrong dude! the kernel-default is the DEFAULT!!

Sorry, but you are wrong.
Normally kernel-desktop is default, as lwfinger wrote.

But there are exceptions when kernel-default is installed instead (kernel-desktop does not work on a 32bit CPU without PAE support).

On 2014-03-24 18:56, goro goren wrote:
>
> lwfinger;2632492 Wrote:
>> The default is desktop
>
> You wrong dude! the kernel-default is the DEFAULT!!

He. Well, it is a misnomer, but openSUSE by default installs the
kernel-desktop :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Well…how to know that data? mine: OS 32bit, dunno nada about ‘PAE support’…

tia!

cat /proc/cpuinfo
~> cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 42
model name      : Intel(R) Celeron(R) CPU B820 @ 1.70GHz
stepping        : 7
microcode       : 0x29
cpu MHz         : 1019.535
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave lahf_lm arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips        : 3392.44
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 42
model name      : Intel(R) Celeron(R) CPU B820 @ 1.70GHz
stepping        : 7
microcode       : 0x29
cpu MHz         : 1088.664
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 2
initial apicid  : 2
fdiv_bug        : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave lahf_lm arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips        : 3392.44
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

So kernel-desktop should work on your system, as well as kernel-pae.

Btw, according to intel’s homepage you do have a 64bit CPU, so no wonder that it supports PAE… :wink:
http://ark.intel.com/products/67193/Intel-Celeron-Processor-B820-2M-Cache-1_70-GHz