kernel-default-devel-3.1.0-46.2 [error]

After zypper duo (or zypper up) Tumbleweed Repository will update the kernel on a x64 system.

During installation following error occurs:

Installing: kernel-default-devel-3.1.0-46.2 [error]
Installation of kernel-default-devel-3.1.0-46.2 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /boot/vmlinux-3.1.0-46-default.gz;4ebacc73: cpio: read failed - Bad file descriptor

Abort, retry, ignore? [a/r/i] (a):

My only workaround is to make a downgrade to the standard Kernel.

I hope that this error can be fast solved.

Best Regards

Confirmed. I’ve encountered the same error. The last working kernel is still installed and boots fine, thank goodness.

Same here.

Just the same. Yesterday and today too.
Installation von kernel-default-devel-3.1.0-46.2 fehlgeschlagen:
(mit --nodeps --force) Fehler: Subprocess failed. Error: RPM fehlgeschlagen: error: unpacking of archive failed on file /boot/vmlinux-3.1.0-46-default.gz;4ebbcc00: cpio: read failed - Bad file descriptor

This seems to affect only the ‘kernel-default’ packages. The ‘kernel-desktop’ packages for 3.1.0-46.2 install just fine. So a quick workaround is to switch to the desktop version for now so zypper dup completes, and switch back after the next kernel update.

Doesn’t work. The kernel-default-devel package is affected. It’s only installed if you install the kernel development pattern, or the kernel-sources. I run kernel-desktop, have the development pattern installed, and still need the kernel-default-devel package + I see the error. In the meantime all other kernel-packages have been upgraded. Anyone reported a bug yet?

Actually all 3 of the kernel-default packages are affected (base, devel and just plain kernel-default) - one of my systems has both kernel flavors so I tried each manually - they all fail the same way. What you say makes sense - I made the switch on my laptop that doesn’t have the kernel development pattern, so didn’t have the extra dependency. My original workaround would still get people through their updates if they happen to be running the default kernel but not the development pattern. I suppose another workaround would be to temporarily remove the development related packages. There’s only a few of them, so it’s easy enough to reinstall them once this is fixed.

A bug report seemed unnecessary since this is a pretty obvious error (and quite rare at that). I expected a fix to come pretty quickly. Guess I was wrong. QA for package updates must not require a successful install, just successful build and packaging.

At least I can confirm no problems here installing kernel-desktop-3.1.0-46.2.x86_64 and kernel-desktop-devel. From my zypp history:

2011-11-09 16:39:04|install|kernel-desktop-devel|3.1.0-46.2|x86_64|root@linux-1pmj|Tumbleweed|...
# 2011-11-09 16:39:36 kernel-desktop-3.1.0-46.2.x86_64.rpm installed ok

2011-11-09 16:39:36|install|kernel-desktop|3.1.0-46.2|x86_64|root@linux-1pmj|Tumbleweed|...

No problems with the reboot. I also have kernel-devel and kernel-source installed, but 3.1.0-46.1 for both.

rpm -qa | grep kernel- | grep 46

is what I have. Laptop runs fine, no issues, but the versions should be the same for all the packages. Personally, I’m giving the packagers some time.

I confirm the error of the default kernel. But since i use the kernel named kernel-dektop and not the default i`m not affected.

creatura@creation:~> uname -a
Linux creation 3.1.0-46-desktop #1 SMP PREEMPT Mon Oct 24 20:49:37 UTC 2011 (1cba112) x86_64 x86_64 x86_64 GNU/Linux
creatura@creation:~> rpm -qa | grep kernel- | grep 46

But OM*G where is kernel-source 3.1.0-46.2? With the next reboot I will have to rebuild NVidia blob, but… I have no sources of 3.1.0-46.2, it means that I will not see my ugly gnome3 :’(

The fault has been reported on the factory mailing list and has been ascribed to “Now it’s all being rebuild due to util-linux change. So it will fix itself after some time hopefully.”
I suppose we just stay away from it for a while.

BTW, I don’t have kernel-default-devel.

WRT expecting same versions, we have been there before with a minor kernel update (but with no errors) as you may recall from an older tumbleweed thread I started: No kernel-source update for 3.0.4-43.2?. So it’s probably no real issue. :slight_smile:

See the link I provided in my previous post re “no kernel-source update” before in tumbleweed, in particular Post #6. You may not need to rebuild, hopefully.

I found this out: I installed kernel-syms a while ago, when I was trying to support someone. Attempting to deinstall kernel-default-devel gave a dependency error, saying it needed deinstallation of kernel-syms as well. I accepted, done.
Another thing: I hadn’t noticed the missing kernel-source package, the new kernel was in a huge pile of updates, so I just checked /boot/grub/menu.lst for correct entries, rebooted into runlevel 3, reinstalled the nvidia driver, no problems at all (so far). Indeed looks like no real issue, at least not a show stopper.

Still no workaround for this?

successfully updated to 3.1.0-46.3.

I don’t see that -46.3 update in Tunbleweed. Is it a typo?

no, a have it.

They already fixed it, 3.1.0-46.3 installed successfully.

@consused, previously I got error in installing the as below in zypper

Installing: kernel-default-devel-3.1.0-46.2 [error]
Installation of kernel-default-devel-3.1.0-46.2 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /boot/vmlinux-3.1.0-46-default.gz;4ebc79e8: cpio: read failed - Bad file descriptor

it was 46.2. Without checking of what version I am upgraded just now via zypper, in YaST it stated that my current is kernel-default-devel-3.1.0-46.3 installed.