Kernel corrupted

When trying to update openSUSE 11.1 kernel-default to the factory kernel-default, openSUSE hung and kernel installation was interrupted.
Now, when trying to start openSUSE it stops with “Kernel panic”.
How can I revert or update kernel without starting openSUSE?

For simplicity - you need the install dvd to repair it.

I have the dvd, I have tried the repair base packages. That did not work.

I would be looking along the lines of ‘boot installed system’ and then retrying what you were doing. As the kernel update did not complete, I think you would stand a fair chance of completing if you gave it another go.

Now, it will not start at all. Is just states that: contains no valid root partition, I suppose the only thing to do now is a reinstall?

:stuck_out_tongue: Don’t you just love guessing and leading people deeper into a problem] What did you try to get this result? and what did you actually do to attempt recovery after the kernel upgrade failed?

The result came from nowhere! After the upgrade was interrupted I had to hard-reset the computer, then trying to start suse again. Then it stated “kernel panic: cannot open sda3 (root partition)”, i think. Then started repair tool from dvd, checking base packages, nothing todo is stated. After posting on forum I tried to start opensuse again, and here we are now, with a root partition with errors the partiton checker on dvd cannot repair.

So what did you try? How did you try to start it?

From GRUB?
Both failsafe and “normal”

Or was you asking for something else?

You can I think use the dvd and proceed repair - use expert and then select the the option that will let you manage the file system and packages.

You may get a load of dependency issues: But the trick is to lock / do not modify every Package except the kernel and any related kernel packages, which you must update.

For example: If you have kernel-source installed, you will need to update that if the update to the kernel means it will no longer match the kernel.

It’s so long since I ever used this feature. But just check around during the process for any options to look at the ‘Booting’ settings - I’m not sure if it will re-write them. If it does it may get it wrong due to a bug. But don’t worry too much about it. If you can get the kernel sorted we have a chance.

That worked! Thank you!
And it was not a error in the install of the kernel, it was the kernel itself, it do not work.

Great that it worked;)