Kernel compile problems, LEAP 15.0


 I am getting this error on my laptop when I compile a kernel 4.16.x, or 4.17 or 4.14.48.  I started with the LEAP 15.0 kernel config and ran make oldconfig, essentially going with the default answer (yes "" | make oldconfig).  I have all of kernel-devel (except 32bit).
CALL    scripts/
make[1]: *** No rule to make target 'm', needed by 'certs/x509_certificate_list'.  Stop.
make: *** [Makefile:1063: certs] Error 2
 I don't get a bzImage.  (4.16.x seems to keep compiling and even goes through modules and modules_install, but no bzImage.)  I tried everything I know to remove what seems to be the offending part of the config, CONFIG_SYSTEM_DATA_VERIFICATION and all things related to X509, but that seems to be prevented by makefiles.  I went searching for everything related to X509 in packman and the normal LEAP 15.0 repos, everything related seems to be installed.

RPMs installed:

Laptop information:

Attempted configs:



This package is not intended for building your own kernel. It exists to allow building of external modules for use with distribution kernel without forcing you to do full kernel build.

So what package(s) do I lack?

Some reading for you…

Followed instructions aside from git. gcc and make are already installed. I also researched what packages exist in Slackware-14.3/d (development) and installed all of those (via zypper). Still getting the same error. I made sure I ran make mrproper beforehand. Still no dice.

I stay corrected - kernel sources are split between kernel-devel and kernel-source so one needs both. I just tried and I had no problems building kernel using kernel-default config with

cp /boot/config-4.12.14-lp150.12.4-default .config
make -C /usr/src/linux-4.12.14-lp150.11 O=$PWD oldconfig
make -C /usr/src/linux-4.12.14-lp150.11 O=$PWD

Yeah that’s been installed this whole time (see rpms.txt from OP), I’m not trying to compile the kernel that comes with openSUSE LEAP 15.0. I’m trying to compile different versions, as noted in my OP.

In this case it is irrelevant what kernel-* RPMs are installed. Where kernel source comes from?