Kernel 5.3.18-150300.59.43.1 Radeon 7670 freezes at boot

Hardware: HP ENVY PHOENIX (Core i5-3570, 10GB DDR3, 2TB HDD (btrfs))
Video AMD Turks [Radeon HD 7600 Series] (actually 7670)
Running OpenSuse 15.3 KDE–fully updated to everything (January 30, 2022).
The kernel update prevents boot success. A second or two after kicking-off loading the new kernel-default (5.3.18-150300.59.43.1-x86_64) from GRUB, the video goes and stays blank, HDD stops accesses. The system does not continue booting nor does it recover or give any responses. Had to power-down, then load the previous kernel (5.3.18-59.40.1-x86_64).

Unsure how to proceed. Anybody got ideas?

Hi and welcome to the Forum :slight_smile:
See this thread:

malcolmlewis sent you to the right place, but that thread is a long and sometimes difficult to find things.
See if the ‘workaround’ here helps. It is Comment #5 on that page.

A lot of us with Radeon GPU’s have problems with that new kernel and the workaround fixed it for me.

It was a long time I comment or try to help on among things and this issue. According to bugzilla it is solved. Solution and work around is there. But not for ordinary people. Thanks developers. You made new openSuSE users running away.