Kernel 4.12.14-lp150.12.45 not activated as default if KODO 4.12.14-lp150.202.g0985fc2 was installed

I did install the kernel 4.12.14-lp150.202.g0985fc2 manually to test if console login issue was fixed.
Now installing kernel 4.12.14-lp150.12.45 will not activate it as default.
Default kernel in /boot is still

vmlinuz -> vmlinuz-4.12.14-lp150.202.g0985fc2-default
initrd -> initrd-4.12.14-lp150.202.g0985fc2-default

grub2-mkconfig -o /boot/grub2/grub.cfg
Will not even show new kernel in grub.cfg

Why installing new kernel with yast will not activate new kernel as default and how can I do it manually?

Since your KOTD has a higher version number it is not displaced as the “default” kernel to boot; you should find the last kernel installed under “Advanced options” in the GRUB menu.
Then if everything is OK you can manually uninstall the KOTD and the boot menu should rebuild accordingly.

The new kernel should show up in the Advanced submenu of your grub boot menu. Select and boot from that. And if it fixes your problems, then uninstall the KOTD kernel, as OrsoBruno suggests.

Problem was that all packages of new kernel except kernel itself was installed.
For this reason it was not included in grub.cfg…
Sorry :frowning:

But your comment helped me now to activate as default :slight_smile:


That’s probably because it saw the KOTD kernel as a newer kernel already installed.

If you have not already done so, I suggest that you disable that KOTD repo.