Kernel 4.12.14-lp150.12.28-default panics with Atheros WIFI (ath10k)

I had not restarted my laptop in a while, but today I did (after upgrading) and I was welcomed by a kernel panic.

not syncing: DMA: Random memory could be DMA Accessed

It’s due to the atheros module (http://lists.infradead.org/pipermail/ath10k/2017-September/010089.html)

I managed to boot by adding module_blacklist=ath10k_core,ath10k_pci,ath10k to the boot line in Grub.

I am not sure what Kernel version I had before, but I tried using the others in my Grub without luck.

Hopefully other people might find this post helpful.

I installed Kernel 4.20 from Kernel:stable and the problem has disappeared. The system boots fine and the atheros card works. However I needed to enroll the signature key with mokutils.

For reference


osc signkey --sslcert Kernel:stable >> kernel.sign
openssl x509 -inform PEM -outform DER -in kernel.sign  -out kernel.der
sudo mokutil --import kernel.der

And them use the BIOS mok manager to add the new key. There is more info here https://en.opensuse.org/openSUSE:UEFI#Enroll_MOK_certificate_manually_from_MOKManager (copying the key to /boot/efi does not seem necessary).

See https://forums.opensuse.org/showthread.php/534542-Kernel-firmware-update-20181026-lp150-2-6-1-locks-up-system

I am going to move this thread to Wifi: https://forums.opensuse.org/forumdisplay.php/676-Wireless

I request that both Forum based and NNTP based users do not reply to this thread until my next post indicating it ok to reply. NNTP users you will need to look for this in the Wifi area in 30-minutes or so.

[quote="“john_hudson,post:3,topic:134977”]
See Kernel-firmware update 20181026-lp150.2.6.1 locks up system - Install/Boot/Login - openSUSE Forums

[/QUOTE][/QUOTE]
This thread has been moved from “Install/Boot/Login” openSUSE area to “Wireless” and it is now open again for posting. Thankyou for your understanding during the thread move.

Thanks! This got my system back up. But I have an issue with it. When I go into grub and choose the old kernel I get (I think) the same issue. How can that be?

The problem is in the kernel plus firmware as a combination. If you revert to the previous firmware, the old kernel should then boot. That’s not intended as advice on what to do.

Usually I don’t think of “firmware” as associated with my desktop. Can you explain? Do you mean a backup of the root filesystem? So use snapper to take it back?

Also, In my 20+ years of having Linux as my primary OS, I’ve never encountered this. I would think this would have been caught in testing. How would something like this get through? And is this being escalated? A simple update crashing a system at boot seems extreme to me.

There’s a package called “kernel firmware” which was the immediate cause of your problem. The package contains firmware for a number of devices, and is dynamically loaded into the device on system startup. If I understand it correctly, the firmware for the atheros card is the particular problem you are having.

Yes, a snapper rollback should take you to an earlier version.

I’m having the same problem. I can’t rollback or boot up at all.

In my case, I managed to boot up using kernel_blacklist=ath10k_pci,ath10k_core on the command line. According to Yast and Zypper both the kernel and firmware are at the latest version. I re-installed both and it continues to crash.

It seems I am hit, too. On a reboot today I get a blinking caps-lock. I am completely shut out of the system. This is on a Dell XPS 13.

Here’s how I got my system back up:

  1. Reboot
  2. At the grub screen check your openSUSE 15 and hit “e” for edit.
  3. At the linux vmlinuz . . . line put module_blacklist=ath10k_core,ath10k_pic,ath10k
  4. Hit F10 to reboot with those parameters

This got me in just fine. I then changed grub permanently through Yast with the blacklist above and can boot just fine normally.

Hope this helps.

P.S. I can give you pics and exact details if needed.

Got it! Thanks for answering what should be a simple question.

As a follow up some detailed instructions of how to boot again without wireless:
Press ‘e’ on the boot entry for Opensuse 15.0
On the following screen go to the line linuxefi then add

modprobe.blacklist=ath10k_pci,ath10k_core

at the end of the line as an added kernel parameter.
Press F10 to boot.
Your system should come up without wireless

I am wondering why the previous kernel-version on my system is not booting either. Shouldn’t there be a previous kernel always?
I hope for an update soon. If somebody sees the update and could post here, that would be appreciated.

Unfortunately, I am running under ext4 and cannot use snapper. Is there an easy way to roll back manually?

You could try reinstalling the previous firmware version.

If you can disable your WiFi card in the BIOS, you can probably boot. And then use an ethernet connection to use Yast and install the previous version (use the “Versions” tab).