Kernel 3.12 s2ram problem (Nvidia), 32bit

I upgraded to kernel to 3.11.6 lately and I I found out, that there were a problem with suspend/hibernation. The computer awakes suddenly and CPU fan goes to maximum. It looks like a RAM memory problem. When there are no open applications, and I enter s2ram command - it works. When I open several applications, there is the problem. I have 2GB RAM. When there was the newest version 3.12 I upgraded again - the same problem. I am using Nvidia driver 331.20 now. I had to go back to kernel 3.7. It works perfectly. I am thinking about installing OS 13.1 (64bit) when it is out, but I am afraid that there is kernel 3.11 and I will have the same problem.

I have new information. I have installed new 4GB RAM and tried kernel 3.12 and Nvidia driver 331.20 again. No problem so far. Perhaps 2GB RAM is not enough.

New - bad information. A fresh instal Open Suse 13.1, 64bit. The same problems. Upgrade of kernel to version 3.12.1 did not help. Driver nouveau. I tried proprietary Nvidia driver too - the same result. I am sure that there is something wrong in kernel. The last good kernel for me was 3.7.

Have you filed a bug report? (same username/password as here)

Yes, now, but I am not a linux expert.

It is strange that nobody has this problem. I installed OS12.3 64 bit yesterday, there is kernel 3.7 and suspend/hibernate works. There is noveau driver, so I am sure, that it is a kernel problem. Perhaps my desktop is too old - CPU Intel LGA775 E8400, mother motherboard Gigabite GA-P35-DS3, graphic 8600GT.

On 2013-12-02 07:46, vta 128 wrote:
> It is strange that nobody has this problem.

Yes, there are. The kernel used on 13.1 is known now as broken related
to 32 bit operations: «it is a kernel regression. fixed in 3.11.8.»,
«In short epoll() and select() may do stupid things after resume», etc.

Search for this thread in our mail list:

Date: Sat, 7 Dec 2013 10:09:27 -0500
From: Greg Freemyer <>
To: suse <opensuse at>
Subject: [opensuse] can’t shutdown my 13.1 system?


  • Wait for a kernel update (see the thread in opensuse-kernel)
  • Use a 64 bit version, this is the recommended solution.
  • do not use suspend/resume.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

As I wrote, I installed Opensuse 13.1 64 bit - clean installation lately. When I had the “suspend” problem, I upgraded kernel from “kernel/stable” repository to version 3.12.x and I had the same problem again. So I gave up and installed Opensuse 12.3 64bit again. There is old, but good kernel 3.7 and I have had no problems yet - even with the Nouveau driver. Please let me know, when there is a new kernel where is this problem solved. I am sure that 64bit kernel, version 3.12 was broken.

New info regarding the old problem:

I installed OpenSuse 13.2, I had a suspend problem again - black screen after resume. So what I have done:

  • I installed Nvidia driver - hard way

After that the resume was OK - no black screen, but sometimes the old problem - the computer after several seconds awakes and the CPU fan runs at full speed. I found out that the ethernet card “wake on lan” is set “ug”, there might be a problem.
Next step - I disabled WOL on the ethernet card:

  • ethtool -s xxx wol d

So far it looks good, suspend works. I hope that it is solved. Perhaps these steps might help somebody.