Kernel 3.11 update notification while having kernel 3.14


I just did a fresh openSuse 13.1 install and after it switched to Tumbleweed immediately. Then I did zypper dup like stated here:

, everything in terminal worked but now I get notifications that there is a kernel update:

kernel-desktop-3.11.10-7.1(32 bit) 41,3 MB
Source Timestamp: 2014-02-03 10:41:24 +0100 GIT Revision: 750023e35881c0adaa8df35756c52f64ec4ab190 GIT Branch: openSUSE-13.1

If I accept the update I get:

There is no update candidate for kernel-desktop-3.14.3-29.1.g07d82b6.i686

Here is the list of my repos:

# | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                      | Service--+----------------------------------+----------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
1 | openSUSE:Stable_OSS              | openSUSE:Stable_OSS              | Yes     | Yes     |   99     | yast2  |     |        
2 | openSUSE:Stable_Updates          | openSUSE:Stable_Updates          | Yes     | Yes     |   99     | rpm-md |                    |        
3 | openSUSE:Stable_non-OSS          | openSUSE:Stable_non-OSS          | Yes     | Yes     |   99     | yast2  | |        
4 | openSUSE:Stable_non-OSS__Updates | openSUSE:Stable_non-OSS__Updates | Yes     | Yes     |   99     | rpm-md |            |        
5 | openSUSE:Tumbleweed              | openSUSE:Tumbleweed              | Yes     | Yes     |   99     | rpm-md | | 

Now what did I do wrong and what should I do now :slight_smile:

Ok - I did zypper up from terminal and it updated the kernel and then zypper up and zypper dup did not update anything. Uname -a gives me that the kernel in use is 3.14. Te question is what kernel was updated?

You can have more than one kernel installed.
A “Kernel update” just installs an additional kernel.

Unneeded ones might be removed later on during boot though, by the purge-kernels.service.

And you will continue to see that 3.11 update waiting to go, as I do, but it will not be installed when you zypper dup. It’s a known idiosyncrasy of Tumbleweed. :slight_smile:

Well zypper up installed it and since then no pop ups. I even had an update with other packages so everything works now.

Well it’s your system, even though zypper dup is the recommended update method. “Everything works now”, so what didn’t work before?

I did zypper dup in the first place. Then I started to get those kernel 3.11 update messages so I did zypper up and they stopped.

Oh, now I see. You regard the kernel “3.11 update messages” as a symptom of “not working”. I suppose technically correct, because the scripting that deals with it from 13.1 standard is confused by the different kernel naming by Tumbleweed. So we live with the harmless messages if we don’t want to install an old kernel [by Tumbleweed’s standards]. :slight_smile:

On 2014-05-15 16:56, consused wrote:
> And you will continue to see that 3.11 update waiting to go, as I do,
> but it will not be installed when you zypper dup. It’s a known
> idiosyncrasy of Tumbleweed. :slight_smile:

Doesn’t taboo that patch work?

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

It didn’t work when I tried that.

The funny thing is that the terminal showed me that it was updated, the update messages stoppped to pop out and the kernel in use is sitill the latest 3.14.

If you have Kernel 3.11.6 installed, libzypp wants to install the update to 3.11.10 for this, no matter what the highest kernel version is that you have installed.

I suppose you could also uninstall both 3.11.x kernels instead.
Or tabooing the patch itself (in YaST->Online Update’s left list) should prevent that update to be shown as well (maybe you have to taboo the kernel-3.11.10 package as well).

But I don’t know for sure as I don’t use Tumbleweed/an updated Kernel from a different repo.

I don’t have a 3.11.x kernel installed.

Tabooing the patch didn’t work last time I tried it wrt to preventing the update message.

How to taboo a specific kernel version using YaST? The Version tab lets you click on each version, but only toggles a tick or a cross against it, nothing else it seems.

Yeah, right. I forgot, sorry.

You would have to edit /etc/zypp/locks manually with a text editor then, or use “zypper addlock”. You can lock specific package versions there.
Something like this should do I suppose:

type: package
match_type: exact
case_sensitive: on
solvable_name: kernel-desktop < 3.12

Or run:

sudo zypper addlock "kernel-desktop < 3.12"

See also .

No worries, it’s an unusual feature. Thanks for the arcane stuff. I will certainly try zypper addlock. :slight_smile:

Hm, strange enough, if you add such a lock with “zypper addlock” (or by editing the file manually), YaST will actually correctly show the versions locked in the “Versions” tab and you can even remove the locks for specific versions there (although that doesn’t work really, they will be back on restart).

And it doesn’t allow to set the version-specific locks in the first place… You can only lock/unlock a package completely in YaST.

Yes that worked, and even after a reboot, kernel-desktop versions < 3.12 are now all shown as taboo/locked under YaST’s “Versions” tab.

Just to recap, this was the exact command:

sudo zypper addlock "kernel-desktop < 3.12"

Edit: PS. posted before seeing your latest comments which are highly likely, although I’m not trying the reversals until necessary :D.

Today I made virtual machine openSUSE 13.1 from DVD iso without updating during installation process.
After finishing I disabled all repositories, add Kernel stable repository and made updating to actual stable kernel 3.15.6.
Then I enabled previously disabled repositories, inserted command zypper dup into terminal and saw that system wanted to install kernel 3.11.10.
So I decided to uninstall kernel 3.11.6. This did not help. Updating still insisted on installation of kernel 3.11.10.
I noticed during uninstallation of kernel 3.11.6, that virtualbox-guest-kmp and virtualbox-host-kmp packages went out also. This packages depends on kernel version.
So I added repository VirtualBox [FONT=Arial][size=2]
After this updating was OK, without need for [/FONT][/size]kernel 3.11.10.