kernel and Intel Sound Card


Today, I did update my system according to the ‘Update Applet’ suggestion. Then, I rebooted my system but now my sound card doesn’t work.

I have a Dell Studio machine. Its audio controller, according to the ‘lspci’ command is:

linux-hmv2:~ # lspci | grep -i intel | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

The content of the ‘/etc/modprobe.d/sound’ file is:

> cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

In addition, the sound modules are loaded in memory.

> lsmod | grep -i snd
snd_pcm_oss 43040 0
snd_mixer_oss 14288 1 snd_pcm_oss
snd_seq 51916 0
snd_seq_device 7168 1 snd_seq
snd_hda_intel 415016 5
snd_pcm 76904 3 snd_pcm_oss,snd_hda_intel
snd_timer 20204 2 snd_seq,snd_pcm
snd_page_alloc 8184 2 snd_hda_intel,snd_pcm
snd_hwdep 7144 1 snd_hda_intel
snd 56784 17 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore 6660 1 snd

I appreciate your comments.


Thanks. Its possible your alsa driver is not compatible with the new kernel version. I updated the alsa-update page, referencing the new kernel, here:
Alsa-update - openSUSE

I can tell you what zypper commands to send to update your alsa version to be consistent with the new kernel, if you give me the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

With your PC connected to the internet, if you run the diagnostic script twice (with root permissions) and give me the output URL from running it the second time: /usr/sbin/ I’ll be able to check your mixer.

Pardon me for barging in on your thread, I just want to express my gratitude :slight_smile:

Sound disappeared from the internal speakers in my laptop (HP Pavilion DV7-1030 w ATI Radeon 3450) when I updated to the new kernel
$ uname -a
Linux freddypc #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux

Sound still came out of the line out jack though.

I updated alsa according to your alsa-update page, and the sound came back to the internal speakers - albeit extremely faint. So I opened YaST / Hardware / Sound and maxed out all the volume meters, and then I opened kmix and saw the new meter for Speaker and maxed that out, and now my sound works as before.

The only sound I can’t get is from the “test sound” buttons in YaST :stuck_out_tongue: , amarok and xine play perfectly.

I still need the option
options snd-hda-intel model=hp-m4
in my /etc/modprobe.d/sound , it can be set using the YaST sound page if you don’t want to edit the file by hand.



I followed the steps defined in the Alsa-update - openSUSE page.
Now, the outputs required:

linux-hmv2:~ # rpm -qa | grep alsa

linux-hmv2:~ # rpm -qa | grep pulse

linux-hmv2:~ # rpm -q libasound2

linux-hmv2:~ # uname -a
Linux linux-hmv2 #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux

linux-hmv2:~ # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.ifylLOqC327:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

Here is the information from the script.
Your ALSA information is located at

Thanks so much for your help.


options snd slots=snd-hda-intel

u1Nb.iJWhLrosxI5:ThinkPad T61

alias snd-card-0 snd-hda-intel

Just works from default install - No messing about.

What is a “Dell Studio machine” ? Is it a Dell Studio 15 laptop ? (1535 or 1537 ? ). Or is it a Dell Studio 17 laptop ? Or is it a Dell Studio Desktop ? Dell Studio Hybrid ? Dell Studio Slim Desktop ? Studio XPS Desktop ?

I have a Dell Studio 15 laptop. I have not (yet) tried the new kernel out on it. I’ll likely try that this weekend. … I could compare my settings to yours IF you have the same make laptop, but there is no point in my wasting time doing that, if you have different hardware.

I went ahead this morning and installed the on my Dell Studio 15 laptop. Prior to updating the kernel, I tested my sound on the laptop (it worked) and I ran the diagnostic script so I had a baseline of my functional sound configuration. I had the 1.0.18 alsa rpms installed prior to the kernel update.

After rebooting with the kernel update, sound was broken.

I noted the kmix options were now very limited (less than before the kernel update) and going to YaST > Hardware > Sound > Other > Volume to check for a low volume did not help.

I then updated the alsa drivers to the 1.0.19 “state of the art” alsa rpms using this site as a guide: Alsa-update - openSUSE I sent 6 zypper commands, … one group of 3 updates alsa, alsa-firmware, alsa-tools, alsa-utils, alsa-oss, alsa-plugins, alsa-plugins-pulse, alsa-dev … etc … and the other 3 commands installed alsa-driver-kmp-pae that matched the new kernel version. I then rebooted. I still had no sound, but after going to YAST > HARDWARE > SOUND > OTHER > VOLUME I noted the master volume level was low at 25%. I moved both master and PCM volume there up to 100%. I closed YaST. I started kmix and noted I had all of my kmix mixer controls back. I moved PCM and master there up to around 90% and tested my laptops sound. Sound now worked !!

So I recommend you update alsa to 1.0.19 per the URL I provided above.

Good luck!


my laptop is Dell Studio 1537.

According to your preview reply, I re-run just three ‘zypper’ commands suggested in ‘Alsa-update - openSUSE’. (Excuse me, but may you give me more details about the ‘6 zypper commands’ that you mentioned above. That is not clear for me. For instance how to install the ‘alsa-drive-kpm-pae’ package).

Anyway, I rebooted after apply the 3 zypper commands, then I run that:

linux-hmv2:~ # rpm -qa | grep alsa

and it looks like the system was upgraded. I tried the yast->hardware->sound->other->volume sequence but it didn’t work for me.

Thanks a lot,

Sorry, I got the commands for updating the alsa driver required for my kernel.

Thanks you so much, my sound is back lol!

Great !! Congratulations.

Looks like we have the same make of laptop. Mine is also a Dell Studio 1537.

Thanks a lot for providing this help!! :slight_smile:
I have encountered many problems with the sound on my DELL Latitude E6500, it finally worked and a recent update spoiled my efforts. Hopefully I found this thread as I have the same audio hardware
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
My kernel version is and arch is x86_64.
My distro is openSUSE11.1.

I do not understand your post.

Are you saying you found this thread and after updating your alsa version that your sound now works ok ? … or your sound no longer works ok ?

Dear opensuse 11.1 folks

I have just carried out the kernel update with the same result as described further above,i.e. no sound as long as I am logged in as “user”. However, logged in as “root” sound works fine. Is there anybody else out there with that same experience?

Is there anybody else out there (apart from josanabr) where an alsa update brought the desired effect, i.e. the sound back?

Kind regards



What happens when you add your regular user to group ‘audio’, reboot, and then test your sound as a regular user? Guidance here for that:
SDB:AudioTroubleshooting - how to workaround a permissions problem - openSUSE

Still no sound.

Should you need more information on my PC please let me know.Only this beforehand: my Dell PC produces the sound via an Audigy card (though i don’t no whether here the type of sound card matters at all).

Perhaps I should indeed try and do the also update from 1.0.18 to 1.0.19 though I don’t understand presently what git-rpms are, e.g. in “alsa-1.0.19.git20090224”, which can be found here:
Index of /repositories/multimedia:/audio/openSUSE_11.1/i586.
Can git updates damage my system?


Often audigy card users have problems with their mixer. [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](

Don’t use those rpms by themselves. You also need the alsa-driver-kmp-your_kernel_version if you are going to use the git versions.

There is guidance here for updating alsa: Alsa-update - openSUSE

As for git, you can read up more on it here:
Git - openSUSE

I would also like to thank you! Sound is back.

Hi oldcpu

I just forgot to tick the “mute” button for the “Audigy Analog/Digital Output Jack” in the KMixer. Now sound is back. - Even though my sound problems turned out not to be due to kernel update or a permission problem - thanks a lot for your support!