Kernal panic on first boot after new install of Leap 15.4

I have been using Leap 15.3 installed on an ext4 partition on an SSD.
Did clean install of Leap 15.4 on a different partition on same SSD.
/home is on separate drive.

sha256 sum 45568bf353900796869324932df7fcfa2170fa32abe7461f79f9b82e4d4e7f39

Installation media was on USB.

Installation completed normally.

On reboot grub auto selected the new installation, but after a minute or so the following screen appeared
screen photo

Tried again, installing on a different ext4 partition; same result.

Downloaded and installed Gecko Static 15.4 which uses the Leap 15.4 repos, but a different installer.
It runs OK.

Any suggestions?

Next time, don’t jump into reinstalling, expecting anything to be different. Instead try to let us help you find out why the problem occurs, and fix it. If you try again and it happens again, try booting in failsafe mode to collect diagnostic logs in order to find out what’s going on, or not. You can also try booting the installed system from the installation media. Another option is to clone your 15.3 to the other SSD and try upgrading it instead of creating a new installation.

Oh, and we need to know your hardware information along with problem description. inxi -baz pasted here using code tags is usually good information.

Why did I try reinstalling instead of immediately asking for help?

  1. To double check that the issue wasn’t caused by a mistake I made during the installation.
  2. To check that the issue wasn’t caused by a problem with the root partition itself, by installing on a different root partition.

Anyway, I followed your advice and booted into recovery mode. I didn’t make any changes, but this action alone seems to have fixed whatever was wrong. The system now boots into the normal mode with no recurrence of the kernel panic.

I’d have preferred to find an answer, but everything works now, which was the goal.

Thank you for your response.