kein Tiefschlaf, wenn Deckel vom Laptop geschlossen wird

hallo zusammen,
ich verwende
openSUSE 11.4 (i586)
KDE 4.6.00 (4.6.0) “release 6”

auf einen Fujitsu-Siemens ESPRIMO Mobile 5535

nach einem heute durchgeführten Update mit
zypper up -t package

hat die Funktion “Tiefschlaf” (susppended RAM)
nach dem Schliessen des Deckels keine Funktion mehr. >:(
Weiterhin ist mir aufgefallen, das in der Akkuüberwachung, Energieverwaltung (Leiste)
gemeldet wird “Akku nicht vorhanden”

Ich würde mich über einen Tipp von Euch sehr freuen. :wink:

Vielen Dank.
Viele Grüsse
Fritz

  • fritzhansen wrote, On 10/09/2011 12:46 PM:
    > nach einem heute durchgeführten Update mit
    > zypper up -t package
    >
    >
    > hat die Funktion “Tiefschlaf” (susppended RAM)
    > nach dem Schliessen des Deckels keine Funktion mehr.>:(

Klappt es denn manuell? Entweder über eines der vielfältigen Symbole dafür oder per s2ram an der Kommandozeile?

> Weiterhin ist mir aufgefallen, das in der Akkuüberwachung,
> Energieverwaltung (Leiste)
> gemeldet wird “Akku nicht vorhanden”

Anderes Problem, bitte starte einen eigenen Thread dafür.

Uwe

hallo zusammmen,

nachstehend die gewünschte Diagnose

Tux-jun:~ # s2ram
Machine is unknown.
This machine can be identified by:
sys_vendor = “FUJITSU SIEMENS”
sys_product = “ESPRIMO Mobile V5535”
sys_version = “V1.02”
bios_version = “V1.13”
See SDB:Suspend to RAM - openSUSE for details.

If you report a problem, please include the complete output above.
If you report success, please make sure you tested it from both X and
the text console and preferably without proprietary drivers.

>:(

Nach Eingabe von:
grep -i acpi
im root Terminal kommt keine Antwort. >:(
Abbruch ist nur mit ctrl-c möglich.

Viele Grüsse
Fritz :slight_smile:

  • fritzhansen wrote, On 10/11/2011 07:06 PM:
    >
    > hallo zusammmen,
    >
    > nachstehend die gewünschte Diagnose
    >
    > Tux-jun:~ # s2ram
    > Machine is unknown.

Okay.

> This machine can be identified by:
> sys_vendor = “FUJITSU SIEMENS”
> sys_product = “ESPRIMO Mobile V5535”
> sys_version = “V1.02”
> bios_version = “V1.13”
> See ‘SDB:Suspend to RAM - openSUSE’
> (http://en.opensuse.org/SDB:Suspend_to_RAM) for details.

Guck doch mal unter dem angegeben Link. Da sind weiterführende Diagnosemöglichkeiten beschrieben.
Wenn die Maschine nicht in der Liste steht, kannst Du z.B. an der Kommandozeile als root mit “s2ram -f” das Dingen zwingen, schlafenzugehen.

> Nach Eingabe von:
> grep -i acpi
> im root Terminal kommt keine Antwort.>:(
> Abbruch ist nur mit ctrl-c möglich.

Das ist klar, weil grep nur im Output nach dem angegebenen String sucht. Wolltest Du vielleicht “ps ax|grep -i acpi” ausführen? :slight_smile:

Uwe

hallo Uwe,

ein klein wenig bin ich schon weitergekommen.
openSuSE wurde mit den Optionen “noacpi nofb acpi=off edd=off vga=0x317” gestartet.
Bis auf “vga=0x317” habe ich alle entfernt.
Danach war in der KDE Engergieverwaltung die Batterie auch wieder sichtbar.
Tiefschlaf, Suspended to RAM, mit Zuklappen vom Deckel des Laptops ist auch wieder funktionsfähig.
Allerdings erfolgt kein Restart mit Aufklappen des Deckels, sondern nur mit kurzer Betätigung
der Power on Taste.
Nach kurzer Arbeit mit KDE friert das gesammte Betriebssystem dann plötzlich ein.
Keine Reaktion auf “ctrl-alt tab” oder “ctrl-alt Backspace”
Nur länger Betätigung der “Power on Taste” zeigte eine Reaktion,

In der Kommandozeile für die Diagnose war ein Tippfehler, es sollte heissen “dmesg | grep -i acpi”
Nachfolgend das Ergebnis:

Tux-jun:~ # dmesg | grep -i acpi
0.000000] BIOS-e820: 000000004fd90000 - 000000004fda0000 (ACPI data)
0.000000] BIOS-e820: 000000004fda0000 - 000000004fda1000 (ACPI NVS)
0.000000] ACPI: RSDP 000f88c0 00024 (v02 PTLTD )
0.000000] ACPI: XSDT 4fd9a9aa 00054 (v01 FSC PC 06040000 LTP 00000000)
0.000000] ACPI: FACP 4fd9fe48 000F4 (v03 SiS 671MX 06040000 PTL 000F4240)
0.000000] ACPI: DSDT 4fd9c330 03AA4 (v01 IEC___ Z17M2.0_ 06040000 MSFT 03000000)
0.000000] ACPI: FACS 4fda0fc0 00040
0.000000] ACPI: APIC 4fd9ff3c 00050 (v01 PTLTD ? APIC 06040000 LTP 00000000)
0.000000] ACPI: MCFG 4fd9ff8c 0003C (v01 PTLTD MCFG 06040000 LTP 00000000)
0.000000] ACPI: HPET 4fd9ffc8 00038 (v01 PTLTD HPETTBL 06040000 LTP 00000001)
0.000000] ACPI: SSDT 4fd9be18 00518 (v01 PmRef Cpu0Cst 00003001 INTL 20050228)
0.000000] ACPI: SSDT 4fd9a9fe 0141A (v01 PmRef CpuPm 00003000 INTL 20050228)
0.000000] ACPI: Local APIC address 0xfee00000
0.000000] could not find any ACPI SRAT memory areas.
0.000000] ACPI: PM-Timer IO Port: 0x8008
0.000000] ACPI: Local APIC address 0xfee00000
0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
0.000000] ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
0.000000] ACPI: IRQ0 used by override.
0.000000] ACPI: IRQ2 used by override.
0.000000] ACPI: IRQ11 used by override.
0.000000] Using ACPI (MADT) for SMP configuration information
0.000000] ACPI: HPET id: 0x10398201 base: 0xfed00000
0.008216] ACPI: Core revision 20101013
0.031960] ACPI: bus type pci registered
0.034136] ACPI: EC: Look up EC in DSDT
0.043010] ACPI: Interpreter enabled
0.043017] ACPI: (supports S0 S1 S3 S4 S5)
0.043043] ACPI: Using IOAPIC for interrupt routing
0.045386] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
0.049138] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049174] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049209] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049242] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049276] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049309] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049343] ACPI Exception: AE_NOT_FOUND, Evaluating _PRW (20101013/scan-743)
0.049376] ACPI Exception: AE_NOT_FOUND, Evaluating PRW (20101013/scan-743)
0.049787] ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
0.049964] ACPI: No dock devices found.
0.049969] PCI: Using host bridge windows from ACPI; if necessary, use “pci=nocrs” and report a bug
0.050878] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
0.054670] ACPI: PCI Interrupt Routing Table _SB
.PCI0._PRT]
0.064029] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 *9 10 11)
0.064143] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 *5 7 9 10 11)
0.064251] ACPI: PCI Interrupt Link [LNKC] (IRQs *3 4 5 7 9 10 11)
0.064358] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 *4 5 7 9 10 11)
0.064496] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 9 10 *11)
0.064600] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 9 *10 11)
0.064706] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 *7 9 10 11)
0.064812] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 9 10 11) *0, disabled.
0.065491] PCI: Using ACPI for IRQ routing
0.070497] pnp: PnP ACPI init
0.070538] ACPI: bus type pnp registered
0.072285] pnp 00:00: Plug and Play ACPI device, IDs PNP0a03 (active)
0.072643] pnp 00:01: Plug and Play ACPI device, IDs PNP0200 (active)
0.072733] pnp 00:02: Plug and Play ACPI device, IDs PNP0b00 (active)
0.072788] pnp 00:03: Plug and Play ACPI device, IDs PNP0800 (active)
0.073024] pnp 00:04: Plug and Play ACPI device, IDs PNP0c02 (active)
0.073109] pnp 00:05: Plug and Play ACPI device, IDs PNP0c04 (active)
0.073173] pnp 00:06: Plug and Play ACPI device, IDs PNP0003 (active)
0.073365] pnp 00:07: Plug and Play ACPI device, IDs PNP0103 (active)
0.073442] pnp 00:08: Plug and Play ACPI device, IDs SYN1907 SYN1900 SYN0002 PNP0f13 (active)
0.073517] pnp 00:09: Plug and Play ACPI device, IDs PNP0303 (active)
0.073772] pnp: PnP ACPI: found 10 devices
0.073774] ACPI: ACPI bus type pnp unregistered
1.581616] ACPI: acpi_idle registered with cpuidle
6.299290] ACPI: AC Adapter [ADP0] (on-line)
6.322665] ACPI: Lid Switch [LID0]
6.323938] ACPI: Power Button [PWRB]
6.324187] ACPI: Sleep Button [SLPB]
6.325075] ACPI: Power Button [PWRF]
6.403994] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
6.405480] acpi device:03: registered as cooling_device1
6.406314] ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
6.445189] ACPI: Battery Slot [BAT0] (battery present)

Die Diagnose mit “s2ram -f” habe ich jetzt im Moment noch nicht wieder getestet.
Ich melde mich deshalb nochmals.

Ich würde mich über weitere Tipps von Dir sehr freuen.
Vielen Dank.

Viele Grüsse
Fritz

  • fritzhansen wrote, On 10/14/2011 05:46 PM:
    > openSuSE wurde mit den Optionen “noacpi nofb acpi=off edd=off
    > vga=0x317” gestartet.
    > Bis auf “vga=0x317” habe ich alle entfernt.

Gut.
Ich würde mit s2ram weitermachen.

Gruß
Uwe

So nebenbei, da es vom Themenersteller anscheinend vergessen wurde zu erwähnen: LINUX • Thema anzeigen - kein Tiefschlaf, wenn Deckel geschlossen wird.

hallo zusammen,

Entschuldigung, leider habe ich aus Unwissenheit ein Multiposting eröffnet.
Nachfolgend der entsprechende Link.

LINUX • Thema anzeigen - kein Tiefschlaf, wenn Deckel geschlossen wird

Entschuldigung es war keine böse Absicht, sondern Unwissenheit.

Viele Grüsse
Fritz

hallo Uwe,

mit dem Befehl s2ram im Terminal mit Root Rechten wird
suspend to ram ausgeführt.
Allerdings passiert beim resume suspend to ram gar nicht.
Der Laptop ist wie eingefroren, nur ein power off/on kann ihn wieder zum Leben erwecken.

Würde mich über einen Tipp sehr freuen,
denn ein Laptop ohne powermanagerment ist nur ein halber Laptop.

Gruss
Fritz

Fritz,

da gibt es leider keine magische Tastenkombination. Du musst in den Logfiles (/var/log/messages) suchen und herausfinden, wo das Problem liegt. Eine Hilfe könnte auch sein, mal nach Deinem Latopmodell und “Linux” zu googeln, vielleicht hat schon jemand eine Lösung gebastelt.

Gruß
Uwe

Fritz,

da gibt es leider keine magische Tastenkombination. Du musst in den Logfiles (/var/log/messages) suchen und herausfinden, wo das Problem liegt. Eine Hilfe könnte auch sein, mal nach Deinem Latopmodell und “Linux” zu googeln, vielleicht hat schon jemand eine Lösung gebastelt.

Gruß
Uwe