"kein Aktualisierungs-Repository konfiguriert" -- Tumbleweed

Hallo,

ich habe gestern auf Tumbleweed umgestellt. Wenn ich in Yast jetzt auf Online-Aktualisierung klicke, erhalte ich folgende Warnmeldung:

»Es ist noch kein Aktualisierungs-Repository konfiguriert. Jetzt den Konfigurations-Ablauf starten?«

Wenn ich dies bejahe, startet einfach das übliche Fenster der Repository Verwaltung.

zypper lr -d
# | Alias                               | Name             | Aktiviert | GPG-Überprüfung | Aktualisieren | Priorität | Typ      | URI                                                     | Dienst
--+-------------------------------------+------------------+-----------+-----------------+---------------+-----------+----------+---------------------------------------------------------+-------
1 | Pacman                              | Pacman           | Ja        | (r ) Ja         | Ja            |   99      | rpm-md   | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2 |       
2 | RPM-Lokal                           | RPM-Lokal        | Ja        | ( p) Ja         | Ja            |   99      | plaindir | dir:///home/AW/Downloads/RPMs                           |       
3 | Update                              | Update           | Ja        | (r ) Ja         | Ja            |   99      | rpm-md   | http://download.opensuse.org/update/tumbleweed/         |       
4 | http-download.opensuse.org-d31c134c | openSUSE:Factory | Ja        | (r ) Ja         | Ja            |   99      | yast2    | http://download.opensuse.org/tumbleweed/repo/oss/       |       
5 | repo-debug                          | repo-debug       | Ja        | (r ) Ja         | Ja            |   99      | yast2    | http://download.opensuse.org/tumbleweed/repo/debug      |       
6 | repo-non-oss                        | repo-non-oss     | Ja        | (r ) Ja         | Ja            |   99      | yast2    | http://download.opensuse.org/tumbleweed/repo/non-oss    |       
7 | repo-oss                            | repo-oss         | Ja        | (r ) Ja         | Ja            |   99      | yast2    | http://download.opensuse.org/tumbleweed/repo/oss        |       
8 | repo-update                         | repo-update      | Nein      | ----            | Nein          |   99      | rpm-md   | http://download.opensuse.org/update/tumbleweed/         |       

Wie also kann ich updates zu Tumbleweed kriegen, ohne jedesmal zypper dup?

Ja. Tumbleweed ist eine rollende Distribution, die Pakete werden direkt im Hauptrepo aktualisiert.
Ein “Aktualisierungs-Repository” gibt es nicht (naja, es gibt schon eins für Notfälle, aber das ist normalerweise leer).

Deshalb macht es auch keinen Sinn, YaST->Online Update zu verwenden.

Wie also kann ich updates zu Tumbleweed kriegen, ohne jedesmal zypper dup?

Mit “zypper up”, YaST->Software installieren/entfernen oder PackageKit (“pkcon update”, Apper oder das neue “plasma5-pk-updates”)

PS: Du hast Packman für 13.2 eingebunden (Repo #1). Das ist inkompatibel zu Tumbleweed. Wechsle auf das Tumbleweed Repo! (also ändere openSUSE_13.2 zu openSUSE_Tumbleweed in der URL)

Naja, im repo http://download.opensuse.org/update/tumbleweed/ sind flashplayer-Notnägel. Derartige Patches würde ich schon gerne jeweils alsbald installieren, aber diese Meldung zum fehlenden Aktualisierungs-repo irritiert mich.

Mit “zypper up”, YaST->Software installieren/entfernen oder PackageKit (“pkcon update”, Apper oder das neue “plasma5-pk-updates”)

PS: Du hast Packman für 13.2 eingebunden (Repo #1). Das ist inkompatibel zu Tumbleweed. Wechsle auf das Tumbleweed Repo! (also ändere openSUSE_13.2 zu openSUSE_Tumbleweed in der URL)

Erledigt, danke!

Das ist aber sowieso nur die alte Version die ebenso in repo-non-oss enthalten ist. Und es sind nur die Pakete dort, sie sind nicht als Patch gekennzeichnet.

Auch für flash-player gilt, dass er direkt im Hauptrepo aktualisiert wird, in dem Falls repo-non-oss. (obwohls da in der Vergangenheit Probleme gab…)

Und die Varianten die ich dir nannte installieren sowieso auch alle Patches im Update Repo.