Keeps on disconnecting from WPA2 Enterprise PEAP


This issue has been on-going for every single linux distribution I’ve tried on my laptop.

In my lab, I connect to the wifi using WPA2 setting with PEAP protection using my username and password. Once a while I become disconnected from the internet and I cannot re-connect until i do a full reboot on my system. Sometimes this “solution” doesn’t work and I just have to live with using one of the desktops there for internet.

This happened to me for Linux Mint 17, Ubuntu 14.04 LTS and now on OpenSuse 13.1 I am convinced that this is not a hardware issue because in my home wifi, WEP encrypted environment, I never ever have the issue.

Something to note is that with my netbook I had Linux Mint 16 and later on 17, on 16, it came with a broken network driver which I “fixed” by downloading a package recommended in their forum and I never had this issue. Ever.

Also, everyone else in the lab who own Windows 7/8 or Mac OS X machines do not have that issue. I also never had the issue with my Windows 7 machine.

I have been searching online for a solution for the past few months so far I’ve came up with:

Conclusively I think it’s something to do with the network manager and/or wifi driver on this laptop. It is Lenovo T410S.
According to YAST2 hardware information
My current driver is rtl8192se
and devicename is wlp3s0

I have went to IT desk in my library and I haven’t had too much luck there because they aren’t too experienced with linux systems. They also issued me a certificate which actually made me unable to connect to the wifi system at all.

I was hoping someone knew a solution to this.

Thanks for your time

This type of issue generally requires details, the type you might not be able to share publicly.

First, it might be useful to research the make and model of the AP you’re using. Yes, like everything else it’s possible for the software to favor features more commonly found in Windows. If you’re certain Mac users aren’t having problems, then you might want to find out how they’re configured.

I don’t know how your AP is using PEAP, by distributing certificates on demand or pre-sharing certificates. If the latter, then try using a cert from another machine on your machine.

A clue might be related to your inability to re-connect even after a re-boot. This might mean that your machine has been blocked. Is it possible to access a blacklist on the AP?

Especially if the problem is intermittent, have you inspected and maybe tried different NIC hardware settings? Have you tried both full or half duplex?

As always, can you inspect logfiles, both on the AP and on your own machine?
And, you may want to run wireshark on your machine regularly, it might be able to discover ongoing problems as well as what might be happening at the moment your system disconnects.


I am actually inclined to believe that it’s something to do with my school server and their incompetence. In the beginning of the semester I had to go through some trouble to get my e-mail account unblocked as a “spam e-mail” source. Also they butchered my ssh access. I wish to speak to the IT desk again but I would like to know what kind of information I should be preparing for them

Just wondering, by “school” do you mean grade school or something else? Cause it seems like your school is very advanced for a grade school.

I am enrolled in Undergraduate Theoretical Physics in a University in Canada.

It could be the same problem I had with another RTL chip on a Lenovo. You could try the same solution, just replace rtl8723be with your model.
I actually saw some success with your rtl card in an Ubuntu forum.

If you don’t have Admin access to your network,
You should collect as much information as you can from the client side first.
That would mean inspecting your own network logs and possibly/probably running wireshark. You’ll likely be looking for errors during normal operation as well as what happens in the moments before you disconnect. If you have any experience reading packet captures, you might be able to zero in on the issue fairly fast.
As hank_se suggests, you can try specifying a different NIC model. For years this was SOP but as hardware discovery has improved is not a solution as often. Be aware though that the NIC driver might not be the actual issue but changing the driver might only have implemented a different default configuration (my suggestion to try different config settings).

Hard to speculate without details.
If you do decide to talk to IT Support, provide them with whatever you have been able to accumulate.
And, keep in mind it might not be an easy thing for them to troubleshoot. To them, your running Linux is probably a corner scenario, so might not be high priority if they’re busy.


Thank you for your replies. After interesting conversations with comp-sci department, I think I’ve found the issue. It is server/service problem related issue.

There’s a reason why I called the IT department in my school incompetent because in the beginning of this semester, my school e-mail account was compromised(Blacklisted within the same domain?! ), my SSH and remote access accounts were compromised(They created a new account for me and merged it with the old one unsuccessfully so I couldn’t even log out once I logged in) and my card access were all compromised and I had a lot of “fun” fixing the problems in September.

They have been trying to re-new the entire school website and network systems and not successful at it for the past few months. My lab technician was able to get me wired-connection in my lab and most of my colleagues were having issues getting wireless access today.