Keeping all my installed packages?

With the upcoming 11.2 release, this is something I’d like to know.
I have two machines, desktop and laptop. The laptop is 32-bit, so I can keep my current packages and config while upgrading to 11.2 by doing a zypper dup…

but my desktop is 32 bit and I want to upgrade to 64-bit (it is capable).
I was told I need to do a clean install , so I plan to back up my /etc/ and my home dir, but how can I keep a list of all packages installed, and have yast re-install them later?


I’ve been thinking about this too. I have so many tweaks, scripts and applications installed that it’s going to take me at least a week to get things back after a clean install.

I think there isn’t much you can do except as you’ve already stated, copy the /etc and /home directories.

As for the applications, I assume that after installing them again you can just copy over the appropriate folder from the saved old /home directory to transfer all your settings.

I’ve tried to be disciplined in the beginning and recorded any new scripts I created or any changes I made to scripts in a separate file so hopefully I can just recreate those changes and additions. I’m sure a few changes slipped through the net though.

I read somewhere on here about a member that puts everything into a separate directory and creates soft links to them from the /home folder or something. Won’t help now but maybe worth looking into to make future reinstalls easier.

Yes, that’s what I do :slight_smile: You can also install the application
called suse-sam which is a support analysis tool. I produces a series
of reports on your syste, including all installed rpms and where they
were installed from.

Run it as root, then you can open the html report in a browser.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 18 days 19:42, 3 users, load average: 0.06, 0.06, 0.02
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

OK, can you provide an example of how you set up your links? Also I installed suse-sam and ran it happily, as root from the cli, it scrolls away but then just it seems to just stop once it gets to the suse-sam rpm. where is the report placed?

Here’s my one for the netbook, I can just run it after an install.

cd ~/
rm .bashrc .profile
rm -rf bin
rm -rf .icons
rm -rf .mozilla
ln -s /data/malcolml/configuration/bashrc .bashrc
ln -s /data/malcolml/configuration/profile .profile
ln -s /data/malcolml/configuration/bin bin
ln -s /data/malcolml/configuration/mozilla .mozilla
ln -s /data/malcolml/configuration/icons .icons
ln -s /data/malcolml/configuration/signature .signature
ln -s /data/malcolml/configuration/wallpapers wallpapers
ln -s /data/malcolml/configuration/claws-mail .claws-mail
ln -s /data/malcolml/configuration/Local_Mail Local\ Mail
ln -s /data/malcolml/configuration/gkrellm2 .gkrellm2

On this system for root I have some customized configs eg lm_sensors,
hddtemp etc that use the same linking.

The command to run is sam (eg sudo sam)? It takes sometime to finish,
then it produces sam-<date:time>.html, .log, .report and .xml in the
directory you ran it.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 18 days 21:15, 3 users, load average: 0.10, 0.07, 0.02
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Thanks I’ll give that a try.

You can also script the adding of repositories and zypper in <file
list> as well.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 18 days 21:47, 3 users, load average: 0.89, 0.40, 0.15
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

I dont think you can do that, I think the only way to use the 64bit version is if you do a fresh install.
I know it sucks but I think that is indeed the case.
Truth be told you really dont need to use the 64bit version if the 32bit version is working out for you.
The 64bit version doesnt offer too much over the 32bit anyway, sure you will get a performance boost as 64bit takes advantage of larger amounts of RAM but other then that if you dont edit loads of media or are a hardcore gamer (which is a hard job to do on linux considering most of the games out there only work in windows) you really dont need the 64bit version.
Honestly the only real differences between 64bit and 32bit in OS terms is some added performance depending on hardware, and the kernel.
This is not like going from a Sony Playstation 1 to a Nintendo 64 (although if you asked me I always thought the Playstation was more visually appealing then the N64, but thats because the N64 was cartrage based)

Found what I was looking for:
rpm -qa –queryformat ‘%{NAME} ‘ > installed-software.bak

(do clean install)

to restore:
sudo zypper install $(cat installed-software.bak)

Have you tried your solution yet? Did it work? Looks quite elegant and simple.

Can you explain what the first command does? From what I can figure it looks for all rpm that were installed by user / to a users account and then adds it to a backup file. Is that correct?

Haven’t tried it yet, but will do.

What the first command does is drop all of the installed packages’ names to a text file- e.g. “kernel-default kernel-source libkde4…” without version numbers.

Then we just feed these package names to zypper again after doing a clean install and setting up our repositories.

This is why I like Linux- There are jaw-droppingly simple solutions to common problems just waiting to be discovered.

I tried the above command and I got this message

error: ^‘%{NAME}$: regcomp failed: Invalid content of \{\}

there should be a double dash in front of the queryformat:

rpm -qa --queryformat '%{NAME} ' 

Hmm, you seem to be in the “64-bit sceptic” camp. Why am I not surprised? :slight_smile:

I think that if you like me, transcode videos now and then with handbrake, which takes almost real time to do (about 30 fps on my dual core Athlon to encode to 1.5Mbs MP4), and therefore took overnight for a couple of DVDs, you would appreciate the boost in performance.

YaST has an option to export the installed packages afaik, never used it but if you’re in YaST Software Management and click the menu option ‘file’ it has an ‘export’ option which will create an xml file of all the currently installed packages, same file menu also has an import option so I’d assume it does pretty much the same thing as you’re doing with the commands.