keep the system up to date

hi,

i have noticed that the apps in the suse repos are kinda out-dated,like banshee is 1.6.0 while the latest is 1.8 same thing for amarok and some stuff,so am trying to keep all the packages up to date from the repositories,i added most of the repos and factory types that should make the system up to date,but to no avail.

can anyone help me on updating the system and the application ?

PS i also added the 3 repos for kde 4.5 sc to update to 4.5 but still i didn’t receive any update notice from the software manager.

help is much appreciated.

Hi,

It is a matter of time and manpower. Packagers need time to package and push newer version of apps. So don’t be surprised it isn’t available yet. It is the case with banshee.

For de kde45, you have to do it yourself. yast->install/remove software->repo tab->select kde 45 stable and click the switch packages.

oh right,thanks alot daax,but theres a minor issue,some packages will get downgraded if i tried to switch the packages to the ones in the repos,is that ok ? or ?

It depends? I don’t think that upgrading kde will downgrade any app you have. When you clcik tghe switch packages link in yast, chech the list of modified packages and see if there is one you don’t want to see downgraded. In my opinion, it shouldn’t be an issue here.

what about switching older apps with new versions like in KDE repositories - openSUSE

i’ll also look at the list and see if there something i dont want to downgrade,but i was just wondering if its ok or not to upgrade in general

I upgraded form kde 4.4.4 to 4.5.3 without an itch. It’s up to you, but kde 4.5.3 really rocks for me. :slight_smile:

alright thanks for all the yelp :slight_smile:

On 2010-11-04 19:36, AlaaHossam wrote:

> i added most of the repos and factory types that should
> make the system up to date,but to no avail.

Be careful if you start adding too many repos. Some are stable, some are
not, and some create conflicts.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)