keep losing nameserver address

I did un upgrade from 10.3 to 11.0. Now I have a problem that I keep losing nameserver entry in my /etc/resolv.conf file. I have a Compaq 6820s laptop.
Situation is like this:
When I start my laptop, ethernet is up (I have a static address), but there’s no dns server address. I can add it manually through console and internet will work. If I try to add it through yast, it won’t work. In fact if I entered a address manually into the resolv.conf and open yast-network and enter secondary dns server and then apply, at the end I’ll have an empty resolv.conf.
Essentially, I have to manually enter nameserver every time laptop stsarts and it’s lost after every restart. How can I put it there permanently?

It sounds like you have an adapter configured to update DNS via dhcp. This is a configurable option in Network Settings under DNS/Hostname at the bottom (checkbox). Ensure this is not checked and that you have defined your nameservers you want there also.

Bounce the network stack (/etc/init.d/network restart) [as root] and you should be good to go.

I do have that option selected, but it’s also greyed out and I can not uncheck it.
BTW, my pc has a static address.](

Is there a conf file somewhere, where I can set it up manually?


would you place a picture of General options tab, pls?

I had the same problem with OpenSUSE 11.0.

If you change the network settings to DHCP and then go back to the tab it ungreys the checkbox and you can deselect it.

Then change back from DHCP to static and the problem with the dns setting dissapearing is gone.

Let me know if this works as I am still having problems after doing it with internet connectivity.


I did this, and nameserver now stays written, in yast and resolv.conf file. But now I can’t access internet. At least before, after manually puting dns server name in, I could go online. Now, I can’t, and I don’t see how to undo it.
I can still access local network.

What do you have under the routing tab? Make sure your router IP is entered there