KDM doesn't start after NVIDIA update startx does

I am using openSUSE 11.1 (64 bit) with KDE4 unstable and have recently updated to nvidia 180.18. On rebooting the machine I reached the nNidia spash screen, then a little more of the opensuse boot progress-bar before being dumped back to a command-line login on tty1.

Running “startx” boots KDE as normal [though lacking functionality such as not recognising the wireless card - I’m assuming this is normal]

I’ve tried reinstalling older nvidia drivers, but this has no effect. I’ve also scanned through some posts of people who seemed to have similar problems but haven’t found a solution so far.

I also have Kubuntu installed on the same machine and have performed the driver update without problems.

you probably tried it but in case you missed it:

boot to init 3
as root
sax2 -r -m 0=nvidia

Yes, I’ve tried that without success.

Any more suggestions folks?

Also tried
sax2 -r -m 0=vesa

And tried stepping though
su -c ‘init 3’
su -c ‘init 4’
su -c ‘init 5’

As I say, the driver doesn’t seem to be the problem, since startx gives me a working (at least from the graphics POV) desktop and the driver seems to load initially on boot.

Have you tried changing the windowmanager to gdm as a test, anything in
log at /var/log

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 7:42, 1 user, load average: 0.03, 0.24, 0.39
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

ok folks do I need to post more info, I’m really stuck here. Otherwise it comes down to reinstalling :frowning:

It’s not set to auto login, if so try disabling that. Everything look
ok in /etc/sysconfig/displaymanager, windowmanager and /etc/inittab

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1:35, 1 user, load average: 0.29, 0.25, 0.28
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


I’m sorry, I didn’t notice your reply.

I can’t see any obvious problems in the logs in /var/log/

…It seeems I can’t post any attachments

In my Xorg.xx.log files, the only warnings I have are of the form:
(WW) NVIDIA(0): Mode is rejected: VertRefresh (85.0 Hz) out of range
(WW) NVIDIA(0): (60.000 Hz).

And also warnings about missing fonts like so:
(WW) The directory “/usr/share/fonts/cyrillic” does not exist.
Entry deleted from font path.

I don’t know how to use gdm instead of kdm.

Have enabled the nvidia repo and updated the nvidia drivers using yast?
After running sax2 and cofiguring the display, you should get a graphical login if you run init 5.

@malcolmlewis - you managed to do it again (posting a reply while I was writing one so I didn’t notice it until much later).

I don’t have time to follow through what you are saying right now but I will tomorrow and I’ll get back to you.


Turning off auto-login in /etc/sysconfig/displaymanager fixed the problem though I am not sure whey autologin was causing a problem.

Lots of thanks

I have now (after installing another NVIDIA driver update) run into further similar (perhaps related) problems.

The thread for this new problem is at:
more NVIDIA update X crash fun - openSUSE Forums

(posting this to help anybody with the same problems finding this thread and not the other)

Try to comment this line in /etc/sysconfig/displaymanager


For me it work
Good luke