kdm displays but doesn't work

All thru kde4.0 to 4.2.0 (inital release) kdm worked but after updating
yesterday from the factory repo kdm does not function. The kdm login
screen shows, I can select the user and enter the password but after a
few seconds the kdm screen returns (selecting diff. users or de doesn’t

Xdm works fine (as does startx) and running kdm from the command line
displays no errors. Also, the login manager app in systemsettings opens
the kdesu dialog, accpts the password and then nothing appears. Tried
kdm kde3.5.x and the same.


tail of kdm.log:

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux circus #1 SMP
2008-12-04 18:10:04 +0100 x86
Build Date: 28 January 2009 05:20:44PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Thu Jan 29 10:50:33 2009
(==) Using config file: “/etc/X11/xorg.conf”
(EE) Failed to load module “type1” (module does not exist, 0)
Could not init font path element /usr/share/fonts/TTF/, removing from
Could not init font path element /usr/share/fonts/OTF, removing from
Driver not XRANDR 1.2 capable, ignoring DISPLAYMANAGER_RANDR_MODE_*

Suse 11.1 x64, Kde 4.2beta, Opera 10.x weekly

Sounds similar to my issues.
Try loading iceWM. Fire up a console, run YaST or zypper and
update all available if newer. Then you can probably get past kdm.

See the thread: Oops OS 11.1 once click update to KDE4.2