KDM corruption, x4500


I have installed RC1 KDE LiveCD, X86_64 on a Thinkpad T400 with x4500 integrated graphics. It is a minor problem, but I am experiencing graphical corruption when switching in and out of the KDM manager, with auto-login enabled or not (i.e. between splashes for the latter). The corruption tends to be either black bars or small color scramble areas.

On the other hand, both sleep and hibernate now work reliably. This is great because in beta 5, DVD i586, resuming from sleep/suspend to ram after the lid was closed would cause a permissions error when I attempted to log back in, along with hosing the file system-“error in service module” upon reboot.

I believe the KDM corruption is worth reporting as I did not experience it in Opensuse 11; although occasionally I would get an identify outputs error about a disabled cloned display via KDE personal settings. Hibernate worked, but sleep/suspend to ram did not, and brightness levels were not properly detected by kpowermanager. The same situation existed before and after updating to KDE 4.1.3.

I am unsure of the intel driver version in 11.1 but I did not experience any corruption whatsoever in Ubuntu 8.10-and by extension Linux Mint 6 RC-using the version 2.5 driver from thejaeger repository, as recommended on thinkwiki. Ubuntu, however, has its own concurrency quirks with resuming from ram, even after a workaround. Mandriva 2009, has no corruption problems either with the 2.4.2 driver, but neither suspend nor hibernate worked properly. Fedora 10 has no corruption problems, but sleep (nor hibernate, I think) did not work. This is strange, because it ships with the 2.5 driver, to my knowledge.

So, in spite of the KDM corruption, opensuse 11.1 RC1 seems to fair the best, as hibernate and suspend to ram both work properly. Not to mention, the implementation of KDE 4.1.3 is most impressive and stable; though Mandriva 2009 is very nice as well.

Nevertheless, seeing as the GMA 4500 series have become popular, it seems to me an important thing to address. The large distros are having mixed successes and failures in support.

I have the same problem on my Toshiba U400, but I am less lucky, hibernate does not work. Now I’m using Archlinux with latest X.org, however, the problem is still there, I use xorg.conf file from previous Opensuse 11.1 and add vga=773 to kernel line in the menu.lst file in /boot/grub folder, and use gdm(not sure about kdm), the problem seems to be minimized.