KDM 4.5 Font Issue

Hi, I am new to this distribution and was eager to run the latest kde since gnome got boring and too simplistic for me. You guys have the best implementation.:slight_smile:

There is one problem though, when I am running it on my laptop panel the fonts in kdm login manager appear to be stuck at 120 dpi and everything looks out of place even though the desktop is set to the correct 96 dpi. I have looked everywhere for settings, changed profiles and even reinstalled kdm but it does not display correctly. When hooked up to the external monitor (24" NEC at 1920*1200) everything seems correct. Please help, the login window looks bad :\

The specs of my laptop are as follows:

Dell M4500
OS: openSUSE 11.3 x86_64
CPU: i7 extreme 920xm
GPU: quadro fx 1800m
GPU DRIVER: Official NVIDIA 260.19.12

Did you run the install originally using the external or the ordinary laptop screen?

Have you tried adjusting via

System Settings>Appearance>Fonts>(Force fonts DPI option)

I initially musunderstood your issue. Same issue reported in this thread.

The solution involved adding these options

Option “UseEdidDpi” “FALSE”
Option “DPI” “96 x 96”

within a config file: /etc/X11/xorg.conf.d/20-nvidia.conf (or 50-screen.conf should be ok too)

Hope this works for you. :slight_smile:

Thank you for your fast replies. I will try these solutions when I get back from university (I’m in Toronto, Canada).

I have no 20-nvidia.conf and in my 50-screen.conf I only have a screen section and adding it there does not work. The Arch forums mentions adding this to the device section. So I simply added those to lines to the device section of my xorg.conf and now everything seems good. Is this a good solution or may this cause problems later?

I have no 20-nvidia.conf and in my 50-screen.conf I only have a screen section and adding it there does not work.

No, I didn’t expect you would have 20-nvidia.conf (this will be distro-specific).

The Arch forums mentions adding this to the device section. So I simply added those to lines to the device section of my xorg.conf and now everything seems good. Is this a good solution or may this cause problems later?

Yes, 50-device.conf is probably the correct place. Good work. It won’t cause any problems later.

Thank You for all your help.

You’re welcome.