KDevelop 3.5.10 and OpenSuse 11.1 - Broken?

Hi All,

I’m having a difficult time compiling a ‘Simple C++ project’ generated by the wizard. What the hell happened???

configure seems to work OK:

configure: WARNING: unrecognized options: --enable-debug
checking for a BSD-compatible install... /usr/bin/install -c
config.status: executing libtool commands
configure: WARNING: unrecognized options: --enable-debug

g++ is invoked, but immediately spews erros:

mv -f .deps/test.Tpo .deps/test.Po
/bin/sh ../libtool --tag=CXX --mode=link g++ -O0 -g3 -o test test.o 
../libtool: line 444: /bin/sh: Too many open files in system
../libtool: line 444: /bin/sh: Success
../libtool: cannot make pipe for command substitution: Too many open files in system

Then I get hundreds of the following.

../libtool: line 718: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 719: *** Future versions of Libtool will require -mode=MODE be specified.: command not found
../libtool: line 751: : warning: cannot infer operation mode without MODE-ARGS: command not found
../libtool: line 6512: : you must specify a MODE: command not found
../libtool: line 6513: Try ` --help' for more information.: command not found

Per [1], I executed the following with no joy.

  • zypper install -f libtool kdevelop3

Any ideas? I looked and project settings but I’m not familiar enough with KDevelop to know how to pull the extra build crap out of the project. I also could not locate a kdevelop4 download (to go with this OpenSuse 11.1/KDE4 installation).


[1] Cannot build “hello world” after upgrading 10.1 -> 11.1 - openSUSE Forums

We have noticed this behavior also. I am surprised no one else has replied. We simply had to stop using KDevelop.

It is not really an acceptable situation - but I personally got sick of googling for an answer, and getting no useful information.

Now we just use Eclipse with the CDT environment.

apparently neither you nor noloader have a perfect grasp of exactly
what this forum is about…it is an openSUSE forum…

i think it unwise to therefore assume that you can get specific useful
information on every program which can be forced to run in openSUSE…

there are, on the the other hand, forums for both KDE and KDevelop,
where it might be reasonable to expect specific useful information on
either of those…

try them, where you will find that KDevelop is in beta with their
KDE4 release, and you can personally determine why the KDE folks
upset your apple cart by moving from 3 to 4:



The problems with KDevelop are not OpenSuse-specific. I did my own Web search when I was unable to get it to work, and discovered that a bunch of people (across all different distributions, too) were having issues.

Hopefully, they’ll be fixed in the next series of releases.

For now, if you’ve just got to have KDevelop, see if you can find an older release and use that.

I too found libtool problems running KDevelop 3.5.* in KDE 3.5.10 installed with openSUSE 11.1. I was able to install and build a C++ program with KDevelop but the debugger did not work. gdb (the debugger) would not start. libtool must run prior to gdb and the libtool version installed in openSUSE returns an error so gdb never gets started. libtool 2.2.6 is installed with opensuse 11.1. According to KDevelop, Kdevelop 3.5.* requires a libtool version >= 1.4, but in opensuse 11.1 (and many other distributions from what I read) it will not run with libtool 2.2.6, so KDevelop’s statement of requirements is wrong. KDevelop apparently no longer works on version 3.5., having moved on to version 4.. I got the debugger to run. I downgraded to libtool 1.5.22 and added libltdl 1.5.26 in opensuse 11.1 and now the debugger runs. I get a configuration warning when I run configure that worries me but I’ve seen no bad behavior yet. I also get a security warning because of the libltdl version 1.5.26 but so far no problems with that. If my analysis is correct, opensuse could resolve the problem in 11.1 by eliminating these dependency problems but that may not be so easy.

The is nothing wrong with kdevelop 3.5.5

The whomever produced the packaging for kdevelop 3.5.5 did a very poor job and in general did a great disservice of all users of kdevelop 3.x.y series of IDE’s

The fix seems to be simple and it has worked for me.

  1. copy /usr/share/libtool/config/ltmain.sh to a working directory
  2. copy /opt/kde3/share/apps/kdevappwizard/template-common/admin.tar.gz to the working directory
  3. copy /opt/kde3/share/apps/kdevappwizard/template-common/incadmin.tar.gz to working directory.
  4. remove ltmain.sh from both archives admin.tar.gz and incadmin.tar.gz I used the ark application to do this.
  5. At this point you may now add/replace the ltmain.sh that was in both archive with the one from libtool
  6. replace the existing incadmin.tar.gz admin.tar.gz with the update version in the working directory

Any NEW projects should now work correctly.

In passing I would like all of you to post your displeasure with this oversight since the first openSuSE 11.