kdetv can't get sound from PCI with saa7134-alsa

I have an saa7134 based tv-tuner card. I have configured it in Yast and scanned for channels. But when I try to watch tv in kdetv I get video but no audio.

I noticed that the saa7134-alsa driver module wasn’t loaded at startup so I modprobed it.

Resulting in:

ssouffri@linux-pig5:~> arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 1: Intel ICH - MIC ADC [NVidia CK804 - MIC ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card **2**: SAA7134 [SAA7134], device 0: SAA7134 PCM [SAA7134 PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

After loading the module I was able to watch a channel with audio in mplayer.

mplayer tv://“insert channel” -tv driver=v4l2:device=/dev/video0:alsa:adevice=hw.2,0:amode=1:audiorate=32000:forceaudio:volume=100:immediatemode=0:norm=PAL:channel=217.25

But still no audio in kdetv.

Does anyone know what the problem is and how i could fix it?

something that might help:

After the loading saa7134-alsa i also get a new SAA7134 mixer entry in KMix. When i select one of the channels of SAA7134 KMix indicates the channel is muted but i can’t unmute it.

As nobody came with any help I will tell my story about the saa7134 card I have.

Having no sound with it I searched the internet. More people had similar problems, but solutions were not abundant. The saying goes that Kdetv has no maintainer anymore. People were told to use other products.

I immediately tried your modprobe and then your mplayer statement. It works. I do not understand all the options you give to mplayer, but after some trial I could mplayer let do scanning (it found 11 channels) and found out how to call mplayer to show such a channel.

This all is of course not of any help to you, but I must thank you for providing useful information to me. At least I can view TV now and with some script programming I will make an interface to call mplayer from the GUI with the right parameters

It’s good to know i’m not the only one with this problem. I hope someone will figure out the cause of the issue.

thx for the input.

Maybe this helps someone:
I recently moved from 10.2 to 11.0 (fresh install) and ran into the same problem. kdetv and tvtime had video but no audio. I remember having some issues with kdetv in the past but tvtime worked fine. The same hardware ran ok 10.2 and runs ok in XP (dual boot).
I tried a lot of things I found on the net and none helped. The only conclusion I reached after that - there should be some incorrect mixer settings; especially after I found that if I max out all the volume settings and crank up my amplified speakers I could hear some faint tv audio (on some channels). Whatever ever settings, that was making the TV card lower its output signal (can’t hear anything with the headset directly hooked to the tuner output).
Long story short - I un-installed kmix for kde3 and tried kmix for kde4 (using Yast). I went to kmix settings and selected Line as “Capture” and increased the volume on Line and AnalogMix. That did the trick!
The weird part is that I tried the same exact controls before (with kde3 kmix) and had no effect.
I ran some experiments after this and found that I could revert to kde3 kmix and I still have TV audio. Another observation is that after using kde4 kmix, the overall volume level has increased (as in “the volume at maximum is significantly louder that it used to be”) not only for TV.
My configuration (relevant to this topic):
openSUSE 11.0 x64, Audigy 2 Platinum, AverMedia Studio (detected as AverMedia TVPhone98). I use KDE3.5 with a handful of KDE4 programs (therefore the KDE4 base is installed too).