kdesu hangs

Leap 15.0 upgraded from Leap 42.3:

 > which -a kdesu
 > rpm --query --whatprovides /usr/bin/kdesu

So, the 64 dollar question is, which package has won the “/usr/bin/kdesu”?

  • The KDE Plasma 5 package? Or,
  • The KDE 4 package?

Further investigation shows the following, on this system:

 > file /usr/bin/kdesu
/usr/bin/kdesu: symbolic link to /etc/alternatives/kdesu
 > l /usr/bin/kdesu
lrwxrwxrwx 1 root root 23 15. Mai 01:33 /usr/bin/kdesu -> /etc/alternatives/kdesu*
 > l /etc/alternatives/kdesu
lrwxrwxrwx 1 root root 28 23. Jun 2017  /etc/alternatives/kdesu -> **/usr/lib64/libexec/kf5/kdesu***

Indicating that, at least for me, “kdesu” will call the KDE Frameworks 5 form of “kdesu” …

 > rpm -ql kdebase4-runtime | grep -i 'kdesu'

Meaning that, there’s also a KDE 4 version of “kdesu” in the system which, will be called by “/etc/alternatives/kdesu” if the alternatives mechanism has been setup that way …


a man fixed this issue by uninstalling pam_kwallet

Thank you. Same issue here and **pam_kwallet **was the bad guy! Solved

You saved me. Remove of pam_kwallet also helped me.
Did anyone created a bug about it?

pam_kwallet seemed to be the offending package for me also. No more "su root; yast2 -sw_single & " for me!

I didn’t see a good explanation why pam_kwallet could cause this behavior or why it’s not needed anymore. If someone knows then an educational post would be helpful. Otherwise I think this thread can be closed. Thank you to those who answered for their help with this.

There appear to be some design flaws in pam_kwallet.

As to why it is not needed anymore – well, it is still needed as much as before. Or, alternatively, it was never needed. That depends on your point of view.

If you remove pam_kwallet, then you are likely to be prompted for your kdewallet password. And it should be the same as your login password (because that’s how pam_kwallet works). If you don’t mind being prompted for a kwallet password, then you can remove pam_kwallet without causing other problems.

I am using pam_kwallet here, though I have considered uninstalling it (for other reasons).

I did just try “kdesu” with

kdesu konsole

and it worked without any problems. On the other hand, I have also tried “lightdm”, and that is badly broken if “pam_kwallet” is installed.

YES, sudo zypper rm pam_kwallet (pam_kwallet uninstall) worked!
Now I don’t need to do a complete install from scratch … :slight_smile: